UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > Specific Vintage Equipment > Vintage Radio (domestic)

Notices

Vintage Radio (domestic) Domestic vintage radio (wireless) receivers only.

Closed Thread
 
Thread Tools
Old 18th Jun 2011, 12:40 am   #1
westcliff
Hexode
 
westcliff's Avatar
 
Join Date: Jan 2011
Location: Essex, UK
Posts: 377
Default KB FB10 "Toaster"

I've acquired this little radio but have some problems to sort out. The bottom of the front of the radio has snapped off, being attached only where it is glued to the grille cloth. A semi-circular piece has also snapped off the base and the tuning knob had seized.

Internal examination revealed the celluloid scale backing plate was missing, the drive cord was just string and one of the dial attachment pillars had snapped off and was nowhere to be found.

I know that the valve line-up on these radios was subject to occasional change, so for the record, my one has the following:

V1 - 6BE6
V2 - 6BA6
V3 - EBC90 in a shielding can
V4 - KT63
V5 - 5Y3GT

The intention is to repair the case using epoxy with fibreglass backing, and car body filler to fill in the spaces. Then it will have to be re-painted.

Is the correct cream colour easily available? If not, it's going to be a custom colour which Mrs Westcliff will choose, as the radio will be hers.

I managed to get the tuning mechanism working with the application of sewing machine oil, but that drive cord will have to go. The wavechange switch has been cleaned and the loudspeaker removed.

Underneath, it's mostly quite clean, although the components at the output valve end are all blackened. Someone has added a Hunts 25uF 25v electrolytic capacitor between V4 and chassis, with the chassis end detached. The wire on V5 pin 8 is (to the OT), is also detached. The mains lead is completely missing. It's not been cut off, it's just not there at all.

Tomorrow I'll make a start replacing the waxies and checking the resistors and I will be using Trader sheet number 969.

If you want to chip in with information, advice or answers, please feel free.

Gus.
westcliff is offline  
Old 18th Jun 2011, 1:23 am   #2
DangerMan
Heptode
 
Join Date: Jul 2009
Location: Stoke-on-Trent, Staffordshire, UK.
Posts: 706
Default Re: KB FB10 "Toaster"

Hi Gus,
there were many different valves used, but as far as I know, no FB10's had rectifiers with 5v heaters, and in fact the rectifier has a common heater supply with the other valves, which is connected to chassis and is 6.3v from an autotransformer. A 5Y3 won't work in this situation, as the HT appearing at the filaments will be shorted to chassis and the heater voltage is wrong any case.

A 6X5GT (or EZ35 equivalent) is the correct valve as it has cathodes insulated from the 6.3v heaters.
Even a 6X5G might foul the fibre shroud inside the handle moulding or the dial diffuser backing, and the output valve should be a 6V6GT, a lot smaller than your average KT63, for the same reason. Perhaps that's why the diffuser is missing.
Good news is, EBC90 is the same as a 6AT6.

Unless the mains transformer has been replaced and the set modified, a 5Y3 would be a disaster if switched on. Maybe it's just been put there to make up the numbers.

Bad news, I know, but I hope this helps

Pete
DangerMan is offline  
Old 18th Jun 2011, 12:00 pm   #3
westcliff
Hexode
 
westcliff's Avatar
 
Join Date: Jan 2011
Location: Essex, UK
Posts: 377
Default Re: KB FB10 "Toaster"

Hi Pete, many thanks for that critical advice. It's not too bad as I have some NOS 6V6GTs I've been hoarding for my Fender guitar amps. I might even have a 6X5 somewhere, although it's probably a G.

I think this radio was more of an ornament than anything else. The complete absence of a mains lead is probably to ensure the set can't be connected to the mains by mistake.

Gus.
westcliff is offline  
Old 20th Jun 2011, 5:58 pm   #4
westcliff
Hexode
 
westcliff's Avatar
 
Join Date: Jan 2011
Location: Essex, UK
Posts: 377
Default Re: KB FB10 "Toaster"

All of the electrics are just about done, apart from the mains lead and a tubular waxy capacitor between S2 on the wavechange switch, and the chassis. It is marked "001 uF" which I imagine means 0.001uF. It isn't on the circuit diagram on the trader sheet. C2, C5 and C6 are shown in that area and they are all present.

I know from reading other threads on the forum that these radios sometimes deviated from the published circuit, so I don't know whether to replace it or just get rid of it.

There was a 25uF electrolytic I mentioned earlier which I removed and didn't replace and I wonder if I should do the same with this one. Any advice please?

Gus.
westcliff is offline  
Old 20th Jun 2011, 9:45 pm   #5
Sideband
Dekatron
 
Sideband's Avatar
 
Join Date: Oct 2003
Location: Croydon, Surrey, UK.
Posts: 5,752
Default Re: KB FB10 "Toaster"

Quote:
Originally Posted by westcliff View Post
I know from reading other threads on the forum that these radios sometimes deviated from the published circuit
Understatement!! I've never found two the same! Yours has a 6V6, both of mine have a 6BW6 (which is basically the B9A equivalent). One of mine has 3x 8.2K resistors in the HT rail, the other has a large 15K. Another variation is a tapped output transformer for hum-bucking. One of mine has it, the other doesn't. Oh yes and one has a ferrite rod and the other doesn't.....

There's loads more variations as well.....

Don't know about the .001. According to the Trader sheet 969, S2 connects to the LW trimmer which is only 70pF. A .001 here will just about kill any signal. The only .001 listed is the aerial coupling capacitor.

None of the versions have a 25uF capacitor on the output valve cathode so you can do away with that.


SB
__________________
On Spike Milligan's headstone......I told you I was ill...
Sideband is offline  
Old 21st Jun 2011, 12:31 am   #6
westcliff
Hexode
 
westcliff's Avatar
 
Join Date: Jan 2011
Location: Essex, UK
Posts: 377
Default Re: KB FB10 "Toaster"

The 0.001 goes straight to the chassis from S2. Perhaps the switch was noisy in the past and somebody thought that a 0.001 cap would be just the job to fix it. The aerial coupling capacitor is in the right place. That 25uF electrolytic was in parallel with R12.

Tonight I glued a semi-circular lug back onto the base and started to prepare the case for repair and painting. One thing I have to do is clean the grille cloth. What is the safest way to clean it? I'd prefer not to unglue it from the baffle if possible.

Gus.
westcliff is offline  
Old 30th Jun 2011, 12:27 am   #7
westcliff
Hexode
 
westcliff's Avatar
 
Join Date: Jan 2011
Location: Essex, UK
Posts: 377
Default Re: KB FB10 "Toaster"

I spent a couple of hours on the bodywork tonight. It took some time to remove the spring clips securing the dial glass and the back panel. One in fact pinged away and will take some time to find. Two of the studs are missing as are four of the clips. I may have to come up with an alternative way of securing the dial glass.

I gave the case a good clean with foam and a child's toothbrush, so now I can glue on the broken section. The plan is to epoxy the broken parts on, there being one large piece and four tiny fragments. When I've done that, the back of the repair as well as a nasty long crack will be fibreglassed. I have the glass fibre so tomorrow I'll buy some resin and hardener.

Later on I was reading some old FB10 threads and I found this one: https://www.vintage-radio.net/forum/...highlight=fb10

I was thrilled to read in post 17 that Andy (AF024), had the same 0.001uF cap as I do, from S2 on the wavechange switch to chassis. His FB10 ended up working well, so I have decided to replace the old wax capacitor with a new one like Andy did.

Here, hopefully, are a couple of pictures of the radio, as I received it.

Gus.

Click image for larger version

Name:	20110503KB 001.jpg
Views:	323
Size:	74.6 KB
ID:	53206

Click image for larger version

Name:	20110503KB 002.jpg
Views:	272
Size:	41.5 KB
ID:	53207
westcliff is offline  
Old 18th Jul 2011, 1:21 pm   #8
westcliff
Hexode
 
westcliff's Avatar
 
Join Date: Jan 2011
Location: Essex, UK
Posts: 377
Default Re: KB FB10 "Toaster"

I've not been idle since I last posted on this thread, I just had plenty of other things to do.

Having finished my work on the chassis, I glued the case together with my Poundland epoxy. Of the smaller fragments, I used just one, to fill in the gap by the volume control. Over the weekend I fibreglassed behind the cracks and used P38 car body filler on the front of the set. Last night and this morning I sanded it down and now it's ready for a coat of primer, to see if the cracks will be invisible.

I'm in the middle of making a spray booth out of an old box which previously contained a computer monitor. When it stops raining, the spray booth will be installed on the seat of my outside toilet and I'll start spraying.

My friend gave me another FB10 for parts, to aid my restoration. The good news is that I have more than enough dial glass clips. The bad news is that the "scrapper" FB10 is complete and in good condition. It even has a nice tidy ferrite aerial and a 6BW6 output valve. The main problem with it seems to be dust and cobwebs, and a broken dial cord. I've not been renovating radios for long, but it looks like an easy restoration for someone. I never thought that this hobby would lead to a crisis of conscience.

Gus.
westcliff is offline  
Old 18th Jul 2011, 7:47 pm   #9
Herald1360
Dekatron
 
Herald1360's Avatar
 
Join Date: Feb 2007
Location: Leominster, Herefordshire, UK.
Posts: 14,574
Default Re: KB FB10 "Toaster"

Clearly you now need another, really scruffy, FB10 so you can finish your case rebuild one and restore the scrapper and salve your conscience.
__________________
....__________
....|____||__|__\_____
.=.| _---\__|__|_---_|.
.........O..Chris....O
Herald1360 is offline  
Old 18th Jul 2011, 9:40 pm   #10
westcliff
Hexode
 
westcliff's Avatar
 
Join Date: Jan 2011
Location: Essex, UK
Posts: 377
Default Re: KB FB10 "Toaster"

That's what I was thinking Chris. There's no way I can destroy the donor radio. I have decided to "borrow" from it the parts I need and replace them when I can. Sounds like embezzlement, doesn't it?

Here are some pics of the repaired damage. I was generous with the fibreglass hardener because there is a long crack I want to stay closed.

Gus.
Attached Thumbnails
Click image for larger version

Name:	GP406 III 011.jpg
Views:	259
Size:	29.7 KB
ID:	54096   Click image for larger version

Name:	GP406 III 012.jpg
Views:	247
Size:	33.2 KB
ID:	54097   Click image for larger version

Name:	GP406 III 013.jpg
Views:	268
Size:	61.0 KB
ID:	54098  
westcliff is offline  
Old 18th Jul 2011, 11:43 pm   #11
Herald1360
Dekatron
 
Herald1360's Avatar
 
Join Date: Feb 2007
Location: Leominster, Herefordshire, UK.
Posts: 14,574
Default Re: KB FB10 "Toaster"

I think the official term is "cannibalizing". We've all done it.
__________________
....__________
....|____||__|__\_____
.=.| _---\__|__|_---_|.
.........O..Chris....O
Herald1360 is offline  
Old 3rd Sep 2011, 12:02 am   #12
westcliff
Hexode
 
westcliff's Avatar
 
Join Date: Jan 2011
Location: Essex, UK
Posts: 377
Default Re: KB FB10 "Toaster"

The body has been finished for a few weeks now. I'm happy with the finish, my first radio respray, although it is still possible to see the cracks from many angles.

I needed a grille cloth as the old one was badly faded. I'm very lucky to have Sid Chaplin only a couple of miles from my house, so I called him and he sorted me out with a lovely cloth, just what I was looking for.

I fitted the cloth by following advice from this forum. The cloth was stretched on a wooden frame and nailed in place. Glue was applied and the baffle board was stuck to the cloth and left weighted down for the night. The next day, I pulled out the nails and trimmed off the excess cloth. I was very pleased with the result as the cloth is perfectly straight. It looks good in the radio.

Tonight I dug out the lamp limiter and started to test the set. At first the lamp glowed dully and the dial lamp did not light up; nor did the 6X5GT I'd recently bought. A dial lamp and rectifier were cannibalised from my donor FB10.

The next time, the lamp limiter glowed more brightly and the dial lamp illuminated. The replacement rectifier also lit up as it should. After a while, LW sound came faintly from the speaker. There were a few channels picked up, then more on MW. The lamp continued to glow with no change in its brightness and there was a buzzing noise accompanying the stations I was listening to. Because of the buzzing and the lamp limiter staying bright, I switched off rather than put full mains through the set.

My inclination is to replace the electrolytic capacitor can with the one from the donor FB10, see if that makes a difference. Comments and suggestions will be most welcome.

Gus.
westcliff is offline  
Old 3rd Sep 2011, 12:25 am   #13
electrogram
Heptode
 
Join Date: Jul 2008
Location: Hereford, UK.
Posts: 601
Default Re: KB FB10 "Toaster"

The smoothing/resevoir cap in these sets is unreliable, unlike that in the Bush dac 90a. It has about 250v across it and is physically small and is just waiting to explode ! I would fit new caps . There is just room below the speaker magnet to fit a three-tag strip to which you can connect two separate new caps
electrogram is offline  
Old 3rd Sep 2011, 3:56 pm   #14
westcliff
Hexode
 
westcliff's Avatar
 
Join Date: Jan 2011
Location: Essex, UK
Posts: 377
Default Re: KB FB10 "Toaster"

A new 32uF + 32uF can has been ordered. Cheers Electrogram, your words have saved me the task of removing the can from the donor. I'd become used to these old electrolytics working just fine. I'll post again when the new cap can has been fitted.

Gus.
westcliff is offline  
Old 21st Sep 2011, 12:33 am   #15
westcliff
Hexode
 
westcliff's Avatar
 
Join Date: Jan 2011
Location: Essex, UK
Posts: 377
Default Re: KB FB10 "Toaster"

The new 32uF+32uF can was far too big to fit in the space behind the speaker, so I ordered some single 30uF 450v electrolytics. They arrived at the weekend and I fitted a pair last night.

Tonight I plugged the set into the 100w lamp limiter and ran it with the lamp in circuit. It picked up stations all over MW and a good few on LW but there was a faint buzz right across the dial on both wavebands. The lamp stayed a dull orange throughout.

After 40 minutes, I switched the lamp out, to put full mains through the set. There was an immediate flash and crackle and the set died (I saw all of the valve filaments darkening and the dial lamp went out). The lamp limiter is powered through an RCD; this did not trip off.

Of all the sets I've repaired, six in total, this the first one that has gone bang on me after working on it. Normally when this happens, I replace all of the tubular waxies and as many resistors as necessary, then the radio works. This time, I've already done all of that.

Should my fault-finding begin with the components I haven't replaced?

Gus.
westcliff is offline  
Old 21st Sep 2011, 7:42 am   #16
Neil Purling
Nonode
 
Join Date: Jul 2005
Location: Hull, East Yorkshire, UK.
Posts: 2,002
Default Re: KB FB10 "Toaster"

If it is totally dead, no heaters I assume you changed C19 (across the mains) for a X2 type. I also assume the mains switch is not playing up.
Are the replacement electrolytic capacitors OK. Check them on the voltage range of your meter first. If they are fine then they may still hold a charge.
See if there is a short to chassis from either side of the resistor between both capacitors.
if one has gone 'bang' it may be obviously swollen or the end is blown outwards.
If the set was drawing excessive HT the flash may have been the rectifier protesting.
I hope it survived.
Remove all the valves and check the auto-transformer. I would hope there is continuity all along that.
With the limiter in risk a quick on-off, with a meter across the heater chain.
It should give a reading close to what you'd expect and something like 8 volts without the limiter when off-load.
If all is well check by putting any valve in apart from the rectifier and if should glow normally.
I wouldn't expect a LT fault. It really sounds as if the set was drawing excessive HT and the rectifier experienced a flash-over. Let us know what you find.
Neil Purling is offline  
Old 21st Sep 2011, 8:52 am   #17
Sideband
Dekatron
 
Sideband's Avatar
 
Join Date: Oct 2003
Location: Croydon, Surrey, UK.
Posts: 5,752
Default Re: KB FB10 "Toaster"

Quote:
Originally Posted by westcliff View Post
Should my fault-finding begin with the components I haven't replaced?

Gus.
Start with the easy bits. Just do some basic resistance measurements when disconnected from the mains. Firstly as the set died, with heaters and pilot light going off, this suggests something at the mains end so firstly, connect you meter, set to read ohms, across the mains lead between L-N and switch on. The meter should read somwhere between 50 and 100 ohms (depends on the actual transformer). Incidentally, if the set has a 13 amp plug fitted, make sure it hasn't taken out the fuse (you did fit a 3 amp didn't you)? If you get no reading, check the plug fuse and the on/off switch (single pole on these). If the fuse and switch are OK then check directly across the transformer. As this set uses an autotransformer, it's just one winding with a tap for the heaters. Somewhere around these parts you should find the problem.

There is very little else left that will make one of these go dead. The worst case is an O/C transformer but I would have thought that unlikely. Maybe the switch didn't like full mains.

SB
__________________
On Spike Milligan's headstone......I told you I was ill...
Sideband is offline  
Old 21st Sep 2011, 11:38 pm   #18
westcliff
Hexode
 
westcliff's Avatar
 
Join Date: Jan 2011
Location: Essex, UK
Posts: 377
Default Re: KB FB10 "Toaster"

Thank you Neil and Sideband for your comments, they are very helpful.

The 3-amp fuse is okay and the resistance on the mains lead between L and N is 162 ohms. I checked my other FB10 and got 171 ohms, so 162 would seem to be acceptable for this model.

While I was checking the mains transformer (142.5 ohms), I saw that a resistor had become detached from its wire. The resistor is R13 I think (the Trader sheet is not clear), and it should have a value of 113 ohms. This one, when removed, measured 9.5 ohms. It is the rectifier's surge limiter and is situated on top of the chassis, between the 6V6 output valve and the aerial.

Can this be the source of my problem, or another sympton? It will have to be replaced in any case. I don't know the power rating of the resistor, but I could use a 5-watt 120 ohm one, or 2 x 5-watt 250 ohm in parallel, for 125 ohms. Would either or both of these be suitable?

Thanks again.

Gus.
westcliff is offline  
Old 22nd Sep 2011, 12:26 am   #19
DangerMan
Heptode
 
Join Date: Jul 2009
Location: Stoke-on-Trent, Staffordshire, UK.
Posts: 706
Default Re: KB FB10 "Toaster"

Hi Gus,
I think you've found a likely candidate for the trouble. A 5W resistor should be ok (DAC90 used a 1 watt carbon one) but keep it away from heat sensitive bits or wires.
With a low value surge limiter, the surge as the voltage suddenly stepped up when you switched out the limiter could cause a hefty current pulse.
I'd replace the resistor, then retry using the lamp limiter. Don't just switch it out though, I'd be inclined to switch off and then give the set a minute for the heaters to cool down before switching on again without the limiter. That way there'll be no big voltage step onto hot valves.

Pete
DangerMan is offline  
Old 22nd Sep 2011, 6:40 am   #20
Neil Purling
Nonode
 
Join Date: Jul 2005
Location: Hull, East Yorkshire, UK.
Posts: 2,002
Default Re: KB FB10 "Toaster"

A 113 ohm surge-limiter. Is that what the bands on the resistor suggest as well, or is the component burnt too badly to read? Try 120R rated 1 or 2 watts. 1W ought to be enough.
Kolster-Brandes are notorious for making un-documented changes of all kinds in this model, so expect discrepancies between the Trader sheet and what you have in real life.
The rectifier should have survived the abuse. If not, send me a PM.
Neil Purling is offline  
Closed Thread

Thread Tools



All times are GMT +1. The time now is 4:15 am.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright ©2002 - 2020, Paul Stenning.