UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > Specific Vintage Equipment > Vintage Television and Video

Notices

Vintage Television and Video Vintage television and video equipment, programmes, VCRs etc.

Reply
 
Thread Tools
Old 22nd Apr 2019, 9:45 am   #1
Vectamart
Pentode
 
Vectamart's Avatar
 
Join Date: Feb 2007
Location: Ventnor, Isle of Wight, UK.
Posts: 106
Default Sony KV1320UB

I bought this set on eBay about 12 years ago. Apart from the CRT emission being a bit low, there was uneven brightness with the left hand side being dark.

I successfully managed to reactivate the tube with my trusty B&K 467 and quickly repaired the brightness fault by replacing C615 (4.7 mfd/250V) on the power board. After a quick squirt of servisol in the user controls, the set now performs very well, given that it is now 48 years old.
Vectamart is offline   Reply With Quote
Old 22nd Apr 2019, 10:18 am   #2
Heatercathodeshort
Dekatron
 
Heatercathodeshort's Avatar
 
Join Date: Jun 2005
Location: Warnham, West Sussex. 10 miles south of DORKING.
Posts: 6,673
Default Re: Sony KV1320UB

Any chance of a pic?
Heatercathodeshort is offline   Reply With Quote
Old 22nd Apr 2019, 11:50 am   #3
Welsh Anorak
Dekatron
 
Welsh Anorak's Avatar
 
Join Date: Apr 2005
Location: North Wales, UK.
Posts: 4,104
Default Re: Sony KV1320UB

I've never beeen successful in boosting one of these tubes. Did you use clean and balance or full rejuvenation?
__________________
Glyn
www.gdelectronics.wales
Welsh Anorak is offline   Reply With Quote
Old 22nd Apr 2019, 12:03 pm   #4
Vectamart
Pentode
 
Vectamart's Avatar
 
Join Date: Feb 2007
Location: Ventnor, Isle of Wight, UK.
Posts: 106
Default Re: Sony KV1320UB

Quote:
Originally Posted by Vectamart View Post
I bought this set on eBay about 12 years ago. Apart from the CRT emission being a bit low, there was uneven brightness with the left hand side being dark.

I successfully managed to reactivate the tube with my trusty B&K 467 and quickly repaired the brightness fault by replacing C615 (4.7 mfd/250V) on the power board. After a quick squirt of servisol in the user controls, the set now performs very well, given that it is now 48 years old.
Apologies for a typo error - the offending component was C613.
Vectamart is offline   Reply With Quote
Old 28th Apr 2019, 7:17 pm   #5
usradcoll1
Hexode
 
Join Date: Mar 2017
Location: Cedar Grove, Wisconsin, USA.
Posts: 293
Default Re: Sony KV1320UB

Quote:
Originally Posted by Welsh Anorak View Post
I've never beeen successful in boosting one of these tubes. Did you use clean and balance or full rejuvenation?
Those early generation Trinitron CRT's usually took to a rejuvenation a little better! Forget about the newer ones.
It's amazing how the B&K rejuvenators gained favor over in Britain!
BTW, You'll have to excuse my poor US style of spelling, but my spell-check won't let me do it properly.
Sincerely, Dave USradcoll1.
usradcoll1 is offline   Reply With Quote
Reply

Thread Tools



All times are GMT +1. The time now is 11:38 pm.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright ©2002 - 2019, Paul Stenning.