UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > Specific Vintage Equipment > Vintage Test Gear and Workshop Equipment

Notices

Vintage Test Gear and Workshop Equipment For discussions about vintage test gear and workshop equipment such as coil winders.

Reply
 
Thread Tools
Old 17th Nov 2018, 7:08 pm   #1
mole42uk
Octode
 
mole42uk's Avatar
 
Join Date: Aug 2010
Location: Bristol, UK
Posts: 1,559
Default Gould 407x display help

I'm still involved in the restoration of the Gould 4074 which is making me work for success. The power supply is now working properly after a full rebuild. The logic is doing everything I'd expect but the display is not nice, as shewn in the accompanying photographs:

The first image is the display when the instrument is first switched on, the second is the display after pressing the 'menu' button. The text can just be read but it has an obvious timing error.

The other problem is that the intensity controls do not work, these images are taken with both the trace and alpha intensity fully anti-clockwise.

I can follow the fault-finding in the service manual, but the chart leads to the 'Bright-Up Amplifier' which is a mess of SMDs. If I could get some helpful pointers it might save my eyes and my hair!!
Attached Thumbnails
Click image for larger version

Name:	IMG_3184.jpg
Views:	108
Size:	51.0 KB
ID:	173003   Click image for larger version

Name:	IMG_3185.jpg
Views:	100
Size:	67.4 KB
ID:	173004  
__________________
Richard

Index:
recursive loop: see recursive loop
mole42uk is offline   Reply With Quote
Old 18th Nov 2018, 10:24 pm   #2
kevinaston1
Pentode
 
Join Date: Aug 2014
Location: Featherstone, West Yorkshire, UK.
Posts: 151
Default Re: Gould 407x display help

I have not looked at the Gould service manual; but my immediate impression is, no CPU reset.


Kevin
kevinaston1 is offline   Reply With Quote
Old 20th Nov 2018, 12:53 pm   #3
dave cox
Octode
 
dave cox's Avatar
 
Join Date: Jan 2009
Location: Bristol, UK.
Posts: 1,196
Default Re: Gould 407x display help

Is there a manual available for download ?

dc
dave cox is offline   Reply With Quote
Old 20th Nov 2018, 1:19 pm   #4
mole42uk
Octode
 
mole42uk's Avatar
 
Join Date: Aug 2010
Location: Bristol, UK
Posts: 1,559
Default Re: Gould 407x display help

I have the manual. It's just that my eyes aren't as good as they once were and the sections of circuit I need to fault-find are all SMDs!
__________________
Richard

Index:
recursive loop: see recursive loop

Last edited by mole42uk; 20th Nov 2018 at 1:27 pm.
mole42uk is offline   Reply With Quote
Old 20th Nov 2018, 4:47 pm   #5
cmjones01
Octode
 
Join Date: Oct 2008
Location: Warsaw, Poland and Cambridge, UK
Posts: 1,809
Default Re: Gould 407x display help

To me that display looks OK but with either the CRT astigmatism misadjusted so the spot is a tall, thin line instead of a fine point, or there's a load of hum or noise on the Y axis which is smearing the image vertically. Check those things first.

Chris
__________________
What's going on in the workshop? http://martin-jones.com/
cmjones01 is offline   Reply With Quote
Old 21st Nov 2018, 4:57 am   #6
Noopy2014
Triode
 
Join Date: May 2014
Location: Eichstätt, Germany
Posts: 14
Default Re: Gould 407x display help

I agree with Chris.
You donīt have a problem with the brightness. You have a problem with a noise on the Y-axis. The lines consume the brightness which should power up only small dot.

But the interesting question is: Where does that come from?

I would suggest the following:

1. Measure the voltage between the plate Y1 and ground and Y2 and ground directly at the base of the CRT.
You should see whether both plate potentials are ok.
If itīs so you have aproblem with your CRT. I donīt know a way to missaligne the CRT in such a way so there could only be a broken Joint in the CRT. If itīs so I would have one in stock.

2. If there is a noise on the Y-deflection it gets more interesting.
The supply for the deflection amplifier supplys first the Y-amp than the X-amp. Noise on the supply should be visible on both deflections which we donīt see.
There could be a defect in the Y-amp. But I would first try to test whether there is a problem with the small signal coming to the Y-amp. Thatīs a bit tricky because itīs a differential current interface. Best way is to activate the external plotter an measure the signal on the plotter interface at the backside of the 4070. This signal is picked up between the Y-DAC and the Y-amp. Strange signals at the plotter interface would lead to the display card. I would suggest to display one grounded channel so you should see a single value for a longer period. If itīs a mess and not a value...
In the end you need either a new DAC08 or you have to do a logic search or you have to do a more ugly search in the SMD-Y-Amp but letīs see what you get. Edit: There could also be a connector problem...

Of course I have some spare parts here...

Best regards,

Richard
Noopy2014 is offline   Reply With Quote
Old 22nd Nov 2018, 1:30 pm   #7
mole42uk
Octode
 
mole42uk's Avatar
 
Join Date: Aug 2010
Location: Bristol, UK
Posts: 1,559
Default Re: Gould 407x display help

Thanks guys, I'll be in the workshop again tomorrow so I'll check. I have a spare tube, so I might try that as well.

I am interested that the brighness controls are both at minimum in the photos are above. That seems wrong.
__________________
Richard

Index:
recursive loop: see recursive loop
mole42uk is offline   Reply With Quote
Old 22nd Nov 2018, 1:56 pm   #8
RogerEvans
Pentode
 
Join Date: Oct 2014
Location: Wiltshire, UK.
Posts: 170
Default Re: Gould 407x display help

Do you know if the brightness controls directly control the CRT voltages or are they just read by the CPU which then sets control voltages via a DAC and analogue multiplexer to set the CRT voltages? Several of the Tek digital scopes use the 'fly by wire' approach and if the DAC references drift then all the analogue settings are affected eg position, trigger levels, brightness ... The advantage of the extra level of complexity is that you can set everything via the GPIB for automated testing.

You may well find a CRT 'grid bias' preset to adjust the present brightness levels to something more acceptable and then readjust when things are fixed.

Roger
RogerEvans is offline   Reply With Quote
Old 22nd Nov 2018, 4:29 pm   #9
Noopy2014
Triode
 
Join Date: May 2014
Location: Eichstätt, Germany
Posts: 14
Default Re: Gould 407x display help

Oh, didnīt realize that the brightness controls are at minimum. Thatīs strange.

The brightness isnīt controled by the CPU, it goes directly to the tube driver amps.
CRT-Settings are the only things that you canīt control over GPIB.

I think you have more than one problem.
Regarding the brightness there could be a problem in the brightness-control-circuit in the CRT-amp. Unfornunately itīs also possible that there is a failure in the power supply which generates the voltage for the voltage control grid. There is a small transistor taking the control voltage from the tube amp and adjusting the control grid voltage around 100V on the Basic high potential (~3kV).
There is also a protection Diode on the tube base board (D1) which in case of failure could lead to a potential on the brigthness-control-grid so that the reading is very bright.
Noopy2014 is offline   Reply With Quote
Old 24th Nov 2018, 11:58 am   #10
mole42uk
Octode
 
mole42uk's Avatar
 
Join Date: Aug 2010
Location: Bristol, UK
Posts: 1,559
Default Re: Gould 407x display help

Updates from inside the 4074 on the workbench:

Have you ever had one of those days when every step makes two more? I started with a display on the screen, replaced a few failed components and finished with a blank screen and no further forward.

Thanks to Noopy2014 I checked the protection diodes on the tube base, three of the four were short circuit (well, ~170R in both directions). I tried the other tube base PCB that I have but that showed no trace at all, so I robbed two of the diodes which tested okay and now the previously working tube base doesn't let the tube display anything.,

I checked the Y amplifier outputs at the tube base, Y1 is 87.5V, Y2 is 87.3V so that seems good. I didn't try my other tube because I got into testing other parts. I did try out my other driver board which displays on the screen in a similar way to the other but it keeps the instrument in self-test because of corrosion from a battery leak some time ago.

I am still concerned that the brightness controls do nothing although I can measure that the trace brilliance control moves from -6V to 1.5V and the alpha control moves from 1V to 2.5V. The trace/alpha switch seems to work, believable voltages on the switch pin and the outputs and the display changes when I press the 'menu' button. The 245V supply to the Bright-Up Amplifier is present so I suspect that there's a failed transistor or diode in the Bright-Up circuit. That's where things start to get interesting, partly because it's all SMD and crammed in under the CRT and partly because the component layout in the service manual that I have is different to the PCB that I have on the bench.

I think the simplest way out might be to replace all the active parts of the Bright-Up amplifier, three transistors and four diodes. My reasoning is that the supply protection resistor (R922, 100R) was o/c and, although I replaced it, the circuit still isn't working. It was probably a failure in the driver transistor Q801, the emitter of which should move between 20V and 60V over the screen intensity range and it doesn't, that popped the resistor R922.

That's all for today, folks!
__________________
Richard

Index:
recursive loop: see recursive loop
mole42uk is offline   Reply With Quote
Old 28th Nov 2018, 7:47 am   #11
mole42uk
Octode
 
mole42uk's Avatar
 
Join Date: Aug 2010
Location: Bristol, UK
Posts: 1,559
Default Re: Gould 407x display help

Well, I decided that I’d make an extender cable to outrig the pre-amp PCB as instructed in the service manual.

I am glad I did because it made testing much easier and soon a 120k resistor dropping 260V because of a s/c zener was discovered. I can’t work out why the 1.3W 120V zener had failed when the supply resistor is only ⅛W and was undamaged. There wasn’t a suitable zener in the drawer so that’s it for a day or so.
__________________
Richard

Index:
recursive loop: see recursive loop
mole42uk is offline   Reply With Quote
Old 28th Nov 2018, 9:45 pm   #12
mole42uk
Octode
 
mole42uk's Avatar
 
Join Date: Aug 2010
Location: Bristol, UK
Posts: 1,559
Default Re: Gould 407x display help

Here's the pre-amp PCB proudly rotated to allow work on the underside and an annotated pic:
Attached Thumbnails
Click image for larger version

Name:	IMG_3206.jpg
Views:	37
Size:	81.0 KB
ID:	173608  
__________________
Richard

Index:
recursive loop: see recursive loop
mole42uk is offline   Reply With Quote
Old 2nd Dec 2018, 3:39 pm   #13
Noopy2014
Triode
 
Join Date: May 2014
Location: Eichstätt, Germany
Posts: 14
Default Re: Gould 407x display help

Iīm really pleased that you make progress!
Noopy2014 is offline   Reply With Quote
Old 3rd Dec 2018, 11:19 am   #14
dave cox
Octode
 
dave cox's Avatar
 
Join Date: Jan 2009
Location: Bristol, UK.
Posts: 1,196
Default Re: Gould 407x display help

You could probably use a couple of lower voltage / lower power ones in series.

0.125W series resistor sounds a bit tiny at that voltage ?

dc
dave cox is offline   Reply With Quote
Old 3rd Dec 2018, 1:54 pm   #15
mole42uk
Octode
 
mole42uk's Avatar
 
Join Date: Aug 2010
Location: Bristol, UK
Posts: 1,559
Default Re: Gould 407x display help

I'd agree except that it survived the 260V - the ⅛W resistor usually drops half that but the shorted zener that drops the other half didn't give it an easy time. I think the PCB layout engineer knew it might be a little critical since the SMD resistor has about 5mm all the way around it on an otherwise pretty densely populated board.

Pondering on some of the design issues in this equipment, one of the things that seems to be evident is that small resistors are used in the supply rail as resistor/fuses so that if a failure occurs that might damage the supply or other parts the resistor becomes sacrificial. There have been two or three that I've found o/c with a down-stream transistor that has shorted c-e to potentially draw a higher current.
__________________
Richard

Index:
recursive loop: see recursive loop
mole42uk is offline   Reply With Quote
Old Yesterday, 9:58 pm   #16
mole42uk
Octode
 
mole42uk's Avatar
 
Join Date: Aug 2010
Location: Bristol, UK
Posts: 1,559
Default Re: Gould 407x display help

Another update: having replaced the 120V zener I now have that supply rail working, and having found the pictured dead transistor and replaced it and the 100R resistor in the supply rail, I now have the 270V woprking again.

There's still no display on the screen, the brightness controls do change the voltage to the bright-up circuit but there's still something wrong in there. It's not made any easier because the layout diagram I have is only a little similar to the PCB I'm working on. This means that every time I need to check a component I have to find out which one it is by tracing the circuit layout on the board. Tedious, yes it is.
Attached Thumbnails
Click image for larger version

Name:	SMD.JPG
Views:	7
Size:	66.3 KB
ID:	174329  
__________________
Richard

Index:
recursive loop: see recursive loop
mole42uk is offline   Reply With Quote
Reply

Thread Tools



All times are GMT +1. The time now is 5:06 am.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright ©2002 - 2018, Paul Stenning.