UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio and TV Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > Specific Vintage Equipment > Vintage Audio (record players, hi-fi etc)

Notices

Vintage Audio (record players, hi-fi etc) Amplifiers, speakers, gramophones and other audio equipment.

Reply
 
Thread Tools
Old 30th Sep 2020, 7:09 am   #1
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 60
Default Trying to revive a Goodmans One Ten receiver

Hi there!
Just won this thing in an online auction here in Sweden for 10 euros.
Have so far just had time to do a quick look through. Lots of dust and some dead bugs, but under the crap it seems to be in pretty good physical shape. Very clean inside though (except for a dead bug jammed in the scale window. Poor thing).

After deciding that nothing looked scary under the hood I plugged it in and got a nice warm scale light but absolutely no sound in the speakers. Tried both A and B speaker connections and radio, aux and phono but just silence. Also worked the input buttons pretty good at no avail. So probably something is wrong electronically. Will start usual troubleshooting looking at fuses and clean contacts and controls. Have the service manuals so can check voltages.
But this being a piece of UK made gear I figured i would pop in here and se if any of you guys have any experience and input that could help me fix this beauty up. Thanks in advance!
Attached Thumbnails
Click image for larger version

Name:	IMG_20200929_202054.jpg
Views:	216
Size:	63.7 KB
ID:	216696   Click image for larger version

Name:	IMG_20200929_202126.jpg
Views:	182
Size:	74.2 KB
ID:	216697   Click image for larger version

Name:	IMG_20200929_210310.jpg
Views:	191
Size:	86.3 KB
ID:	216698   Click image for larger version

Name:	IMG_20200929_203034_1.jpg
Views:	175
Size:	63.5 KB
ID:	216699  
CrazySwede is offline   Reply With Quote
Old 30th Sep 2020, 8:53 am   #2
David G4EBT
Dekatron
 
David G4EBT's Avatar
 
Join Date: Feb 2003
Location: Cottingham, East Yorkshire, UK.
Posts: 4,263
Default Re: Trying to revive a Goodmans One Ten reciever

Welcome to the forum.

I don't recall having seen any Goodmans receivers mentioned on the forum, so can only suggest a few general checks you could carry out to try to narrow down in which sections of the receiver the fault(s) lie. Firstly, it's worth checking at the slider of the volume control (dual gang if stereo) with a signal tracer (or small amplifier) to see if you can hear any tuneable stations on the various wavebands. If so, that would mean that the RF, IF and detector stages are at least working.

As you get no audio to the speakers even when you input audio into the AUX and Phono sockets, it certainly seems like there is a fault/faults in the audio stages. Sometimes such equipment doesn't take kindly to being switched on with no speakers connected or mismatched non-original speakers, causing damaged to the output transistors/ICs.

As you have the manual, as you will know, a good place to start would be voltage checks, but if you're in luck and the RF/IF/Detector stages are indeed working, you could use a signal tracer to follow the audio signal through each stage of the audio section to try to pinpoint the fault.

Hope that might help a bit.

Good luck with it.
__________________
David.
BVWS Member.
G-QRP Club member 1339.
David G4EBT is offline   Reply With Quote
Old 30th Sep 2020, 9:43 am   #3
chriswood1900
Octode
 
Join Date: Jan 2007
Location: Bristol, UK.
Posts: 1,022
Default Re: Trying to revive a Goodmans One Ten reciever

Welcome to the forum.
The Goodmans 110 was a reasonable effort at producing a modern looking receiver. I owned one for a while and was pleased with its performance.
It has appeared before on the forum where part way down are links to the manuals. https://www.vintage-radio.net/forum/...ad.php?t=46056
Standard repair techniques should work, although it is mainly one large circuit board it is in sections. Check power supplies are present and see if you can hear anything at the tape outputs from the tuner or can produce any sound from the inputs. Don't rule out badly corroded switches and din plugs needing a good clean.
Good Luck
__________________
Chris Wood
BVWS Member
chriswood1900 is offline   Reply With Quote
Old 30th Sep 2020, 10:43 am   #4
jjl
Heptode
 
jjl's Avatar
 
Join Date: Jan 2003
Location: Ware, Herts. UK.
Posts: 939
Default Re: Trying to revive a Goodmans One Ten reciever

If the scale lamps PL2, 3, and 4 are lit, at least the mains fuse is intact. I can't find where these lamps take power from in the service manual, but given that they are 12V types they are probably powered from the +14.3V or -14.3V rail. In which case these supplies must be present.
I'd check the fuses in the +35V and -35V rails to the power amplifiers. Don't be tempted to just replace these if they are blown as they will have failed for a reason - most likely failure of output transistors for either power supply variant or rectifier diodes or smoothing capacitors for the earlier variant.

John
jjl is offline   Reply With Quote
Old 30th Sep 2020, 11:04 am   #5
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 60
Default Re: Trying to revive a Goodmans One Ten reciever

Thanks for responding, guys!
How do I figure out if I have an early or later model?

Have some more pics of the internals here if it may give some clues?
Attached Thumbnails
Click image for larger version

Name:	IMG_20200929_203039.jpg
Views:	111
Size:	64.7 KB
ID:	216700   Click image for larger version

Name:	IMG_20200929_203042.jpg
Views:	96
Size:	59.2 KB
ID:	216701  
CrazySwede is offline   Reply With Quote
Old 30th Sep 2020, 12:25 pm   #6
jimmc101
Heptode
 
jimmc101's Avatar
 
Join Date: Mar 2009
Location: Portsmouth, Hampshire, UK.
Posts: 647
Default Re: Trying to revive a Goodmans One Ten reciever

The four fuses on the bracket from the mains transformer suggest that yours is a later model. (See the manual I posted in the link above, pt1 page 6 and pt2 page 2).

Good luck with it.

Jim
jimmc101 is offline   Reply With Quote
Old 30th Sep 2020, 12:37 pm   #7
jjl
Heptode
 
jjl's Avatar
 
Join Date: Jan 2003
Location: Ware, Herts. UK.
Posts: 939
Default Re: Trying to revive a Goodmans One Ten reciever

I see now that the scale lamps are powered from the 12V A.C. available between the 30V and 18V taps on the secondary of the mains transformer. This means that F6 on the later power supply circuit must be intact, but any of the +/- 13.4V and +/- 35V rails may be absent.

John
jjl is offline   Reply With Quote
Old 30th Sep 2020, 6:42 pm   #8
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 60
Default Re: Trying to revive a Goodmans One Ten reciever

A little progress!
Measured continuity over all fuses and the two 18v where open. Fuses where ok but the holders very oxidized. Cleaned them, popped the fuses back and turned it on and we have sound!
...but only static and a lot of popping. Now on to a thorough cleaning of the buttons and potentiometers.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20200930_203530_com.google.android.apps.photos.jpg
Views:	52
Size:	35.4 KB
ID:	216733  
CrazySwede is offline   Reply With Quote
Old 30th Sep 2020, 7:28 pm   #9
vinrads
Nonode
 
Join Date: Feb 2009
Location: Chesterfield, Derbyshire, UK.
Posts: 2,532
Default Re: Trying to revive a Goodmans One Ten reciever

That sounds promising a good clean of all the controls and switches should have it working , Mick.
vinrads is offline   Reply With Quote
Old 30th Sep 2020, 8:55 pm   #10
Reelman
Octode
 
Reelman's Avatar
 
Join Date: Aug 2008
Location: Rotherham, South Yorkshire, UK.
Posts: 1,104
Default Re: Trying to revive a Goodmans One Ten receiver

Glad to hear you are making progress. When it is finally up and running there are a couple of points to be aware of: there will be a thump from the speakers when turning on, this is normal if unpleasant. However in the 20+ years I used mine it never damaged the speakers that were connected for the same Length of time. If you don’t like it then switch on to headphones first and then immediately to speakers. The volume control will be noisy by this time and because of a tapping on the track very difficult to find a replacement.

Other than the above mine never had a fault of any description.....

Peter
Reelman is offline   Reply With Quote
Old 1st Oct 2020, 7:49 am   #11
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 60
Default Re: Trying to revive a Goodmans One Ten receiver

Thanks for input, Peter.
Yup, that thump when powering up had me jumping. Good to read that it is a standard feature .
CrazySwede is offline   Reply With Quote
Old 2nd Oct 2020, 2:57 pm   #12
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 60
Default Re: Trying to revive a Goodmans One Ten receiver

Hmm, this puppy may be worse off than I first thought. A good deoxit clean of all breakers and controls have not helped at all.

Some symptoms so far:
- When I turn it on I get a solid thump in both speakers (happens booth on speaker1 and 2)
- I get no audio from AUX or Phono inputs
- Sometime I can get a loud static kind of loud screeching noise when activate L,M or K radio bands.
- When swithing input I get loud pops in the speakers
- When I get the loud noise described above this happens even if volume button is turned off completely.
- No audio in headphones either.

Going to move on now to check voltages.
One question: could the above described behaviour be a sign of that I still have problems with bad contact in the fuse holders that I described above?
On of them have been hard to get to so not sure if I have managed to clean off the corrosion.
Attached Thumbnails
Click image for larger version

Name:	fuse_f3_f4_1.jpg
Views:	42
Size:	13.5 KB
ID:	216867   Click image for larger version

Name:	fuse_f3_f4_2.jpg
Views:	76
Size:	80.3 KB
ID:	216868  
CrazySwede is offline   Reply With Quote
Old 4th Oct 2020, 11:39 am   #13
Reelman
Octode
 
Reelman's Avatar
 
Join Date: Aug 2008
Location: Rotherham, South Yorkshire, UK.
Posts: 1,104
Default Re: Trying to revive a Goodmans One Ten receiver

One additional problem you need to be aware of is that I think this uses “lockfit” transistors which are known to be unreliable and should be replaced by non-lockfit types. A search of the forum will produce suggested types.
You could try some signal injection directly to the PCB to try and isolate the faulty stage or stages.
Peter
Reelman is offline   Reply With Quote
Old 4th Oct 2020, 11:50 am   #14
stevehertz
Dekatron
 
stevehertz's Avatar
 
Join Date: Sep 2011
Location: Rugeley, Staffordshire, UK.
Posts: 4,945
Default Re: Trying to revive a Goodmans One Ten receiver

There were quite a few Goodmans receivers in different guises, some with built in record decks. The three main (serious!) ones were the Module 90, 'One Ten', and the '150'. I started my hifi career with a Module 90 in 1976 (long gone) and I now have a 150 in my collection of vintage receivers. I am in the process of buying a One Ten from a friend. All models have been featured on here at various times. Out of interest, here's a photo of my restored 150. BTW, I would clean those switches again and with the power off operate them many times. You'd be surprised at how dirty and unresponsive to cleaning they can be sometimes. Best of luck.

Edit. Out of interest, I read or was told in the 70s that a rich Arab Sheikh had bought - I think it was thirty - Goodmans 150s and specified that they were all gold plated. What bits were gold plated I don't know, but anyway, it's a good and somewhat plausible story. I see no reason for someone to make up something so obscure.
Attached Thumbnails
Click image for larger version

Name:	DSCN1120.jpg
Views:	120
Size:	76.0 KB
ID:	216975  
__________________
A digital radio is the latest thing, but a vintage wireless is forever..
stevehertz is offline   Reply With Quote
Old 6th Oct 2020, 7:56 pm   #15
david freeman
Pentode
 
Join Date: Aug 2005
Location: Lincoln, Lincolnshire, UK.
Posts: 213
Default Re: Trying to revive a Goodmans One Ten receiver

The 150 is a superb sounding receiver.
It was the most powerful British made receiver when introducing in 1975.
Had excellent reviews in the HiFi press.
david freeman is offline   Reply With Quote
Old 6th Oct 2020, 8:42 pm   #16
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 60
Default Re: Trying to revive a Goodmans One Ten receiver

Thanks for input!
Have hit the pots and switches with another round of contact cleaning spray (ran out so need to get more) and replaced all fuses. They measured ok but just to be sure they're ok.
But still: only lights and no audio except for a thump on power up and some pops when hitting the switches.
Otherwise same symptoms as I described in an earlier post.
Will get another can of contact cleaner and give it one more try. But if third time is no charm with that method, I need some help to troubleshoot further. I have a multimeter and know the basics about measuring voltages and currents and continuity.
Is there by way to measure if a switch is bad? Any other possible causes that makes this thing quiet?
CrazySwede is offline   Reply With Quote
Old 7th Oct 2020, 7:17 pm   #17
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 60
Default Re: Trying to revive a Goodmans One Ten receiver

By the way, would it be possible to pop the buttons off the switches to get better access for the contact cleaning spray from the front side?
Some of them are hard to reach from inside (caps and stuff in the way of the hole in the back of the switches).
But don't want to break anything either...
CrazySwede is offline   Reply With Quote
Old 7th Oct 2020, 10:56 pm   #18
jamesperrett
Octode
 
Join Date: May 2007
Location: Liss, Hampshire, UK.
Posts: 1,270
Default Re: Trying to revive a Goodmans One Ten receiver

Sounds like a problem with the preamplifier stages. If it affects both channels I'd look at the power supply first (which appears to be the supply associated with the fuses that you mention earlier). The diagram you posted shows the expected voltages at various points in the circuit so I'd start by checking with your meter that those voltages are as expected.
jamesperrett is offline   Reply With Quote
Old 8th Oct 2020, 8:52 am   #19
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 60
Default Re: Trying to revive a Goodmans One Ten receiver

Thanks for that advice, James!

I have started trying to measure voltages and so far I think they check out. This is the outgoing DC:s after the psu at points 13, 24, 25. But after that I have trouble interpreting the schematics and finding the right points to measure imortant voltages (no markings on the board).
Here´s where my inexperience starts to show ...

So if someone with more experince could take a peek at the schematics and give me a pointer where the important measure points in the different areas can be found I would very much appreciate it.

If you tell me at which components to measure I should be able to locate using the layout sheet.

I have attached the servicemanual and the schematics. Also stitch the pages together to make it easier to read.

EDIT: noticed that the forum tool compressed the jpg-images so they may be hard to read. Here´s a shared G-drive folder with the originals.
https://drive.google.com/drive/folde...fX?usp=sharing



But I will also defenitely have to get more contact cleaner and have another go at the switches. Last night while trying more I found at some points/combination of switch presses I got some consistant noise and also a weak audio from the AUX which I had connected to a music source.
Attached Thumbnails
Click image for larger version

Name:	goodmans_110_board_layout.jpg
Views:	51
Size:	135.5 KB
ID:	217283   Click image for larger version

Name:	goodmans_110_schematics.jpg
Views:	50
Size:	130.5 KB
ID:	217284   Click image for larger version

Name:	goodmans_110_schematics_psu.jpg
Views:	38
Size:	82.2 KB
ID:	217285  
Attached Files
File Type: pdf hfe_goodmans_one-ten_service_en.pdf (3.72 MB, 30 views)
CrazySwede is offline   Reply With Quote
Old 9th Oct 2020, 12:02 am   #20
jamesperrett
Octode
 
Join Date: May 2007
Location: Liss, Hampshire, UK.
Posts: 1,270
Default Re: Trying to revive a Goodmans One Ten receiver

My next suggestion would be to check the voltage on pins 14 and 7 of IC2 and IC3. Have you tried feeding a signal into the tape socket with the tape monitor switch engaged?
jamesperrett is offline   Reply With Quote
Reply

Thread Tools



All times are GMT. The time now is 2:42 am.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright ©2002 - 2020, Paul Stenning.