UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio and TV Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > Specific Vintage Equipment > Vintage Audio (record players, hi-fi etc)

Notices

Vintage Audio (record players, hi-fi etc) Amplifiers, speakers, gramophones and other audio equipment.

Reply
 
Thread Tools
Old 12th Oct 2020, 6:27 pm   #21
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 61
Default Re: Trying to revive a Goodmans One Ten receiver

Sorry for slow updating on this. Anyhoo: have dumped another half a can of contact cleaner into the switches but no result.
Tried connecting a signal to tape input but not a sound.
Measured the IC:s as suggested and got:

IC 3
Pin 14: 13,7v
Pin 7: 1,3v

IC 2
Pin 14: 13,6v
Pin 7: 1,3v

This looks not right, right?
Should be +14,3v and -14,3v if I interpret the schematic right?
What now?
Thanks in advance for suggestions for further troubleshooting!
CrazySwede is offline   Reply With Quote
Old 12th Oct 2020, 6:44 pm   #22
tony brady
Pentode
 
Join Date: Mar 2014
Location: Peacehaven, East Sussex, UK.
Posts: 234
Default Re: Trying to revive a Goodmans One Ten receiver

check the voltage on VT41. the negative voltage on IC2 & 3 is not correct.
the +13.6V is close enough on pin 14
tony brady is offline   Reply With Quote
Old 12th Oct 2020, 6:59 pm   #23
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 61
Default Re: Trying to revive a Goodmans One Ten receiver

Tony, thank you so much for advice and taking time to help this poor Swede out. Much appreciated! I have closed shop for tonight but will try to get that VT41 voltage checked tomorrow.
CrazySwede is offline   Reply With Quote
Old 12th Oct 2020, 11:29 pm   #24
jamesperrett
Octode
 
Join Date: May 2007
Location: Liss, Hampshire, UK.
Posts: 1,326
Default Re: Trying to revive a Goodmans One Ten receiver

As Tony says, check VT41 and, if there are no volts on the collector or emitter, check the voltages on R169 and its associated smoothing capacitor. If the voltages on VT41 look correct you need to look for a broken connection between VT41 and the IC's.
jamesperrett is offline   Reply With Quote
Old 13th Oct 2020, 6:33 pm   #25
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 61
Default Re: Trying to revive a Goodmans One Ten receiver

Hi!
Here's some voltages. Hope I got it right ...
The transistor measurements are after markings on the PCB.

VT41
E: -1.33
B: -14,3
C: -25.6

VT40
E: 13.6
B: 14.3
C: 23.6

R169
-25.6

C151
24.7

Ē152
-25.6

R167
-18.6
- 14.6
Measured both sides.

So looks like the E-voltace on VT41 is way off or is my thinking off?

Last edited by CrazySwede; 13th Oct 2020 at 6:45 pm.
CrazySwede is offline   Reply With Quote
Old 13th Oct 2020, 6:59 pm   #26
tony brady
Pentode
 
Join Date: Mar 2014
Location: Peacehaven, East Sussex, UK.
Posts: 234
Default Re: Trying to revive a Goodmans One Ten receiver

it looks like VT41 is faulty and should be replaced
tony brady is offline   Reply With Quote
Old 13th Oct 2020, 8:25 pm   #27
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 61
Default Re: Trying to revive a Goodmans One Ten receiver

Thanks! Good have a course of action. According to the parts list in the service manual it's an e5359 transistor. Have done a quick search but failed to find one for sale. Is it no longer manufactured? Any similar transistor that can replace it?
CrazySwede is offline   Reply With Quote
Old 13th Oct 2020, 8:52 pm   #28
tony brady
Pentode
 
Join Date: Mar 2014
Location: Peacehaven, East Sussex, UK.
Posts: 234
Default Re: Trying to revive a Goodmans One Ten receiver

I think that's a Thorn part number. I don't know what the direct equivalent actually was - what package is it? TO92?

I would fit something like a ZTX753 which are easy to get and more than enough to do the job. just be careful with the pin outs
tony brady is offline   Reply With Quote
Old 13th Oct 2020, 10:30 pm   #29
Chris55000
Octode
 
Join Date: Aug 2007
Location: Walsall Wood, Aldridge, Walsall, UK.
Posts: 1,601
Default Re: Trying to revive a Goodmans One Ten receiver

Hi!

Looking at the pinout at the bottom of the power–supply circuit, VT40 and VT41, are plastic transistors of the TO92b type, and you'll find the BC639 (npn, VT40) and BC640 (PNP, VT41) will be ideal to replace the E5358 (npn) and the E5359 (PNP), and will fit the board exactly the same orientation as the original devices.

Please be aware tho', that simple emitter–follower series stabilisers of this type are NOT short–circuit proof, so take great care not to accidentally short–circuit the ±14V lines whilst making tests!

If either transistor fails immediately after replacing it, there could be an i.c. or decoupling capacitor(s) downstream of VT40 or VT41 defective!

Chris Williams
__________________
It's an enigma, that's what it is! This thing's not fixed because it doesn't want to be fixed!
Chris55000 is online now   Reply With Quote
Old 14th Oct 2020, 4:43 am   #30
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 61
Default Re: Trying to revive a Goodmans One Ten receiver

Thanks for clearing this up. Yup, BC639 and BC640 seems to be easy to find. Since I will be paying shipment I could just as well order more stuff. Do you see any other suspects that I could add to the shopping list to have at hand if the VT41 is not the problem?
CrazySwede is offline   Reply With Quote
Old 19th Oct 2020, 6:18 pm   #31
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 61
Default Re: Trying to revive a Goodmans One Ten receiver

Hi, I'm back.
Finally got the replacement transistor I ordered.
So took a deep breath, trying not to think of how long it was since the last time I held a soldering iron, and went at it.
Thankfully the Goodmans engineers must have had future hifi restorers with big, clumpsy Swedish hands in mind when laying this board out. Not that hard to access and not to crowded. Phew!
Got the VT41 replacement in place, checked and behold: there was minus voltage on the rail again!

So held my breath and mumbled a quiet prayer through gritted teeth to new and ancient higher powers and pressed power...
Big thump in the speakers and then... MUSIC!

Man it was a long time since Bruce Springsteen (playing on my phone through aux input) sounded this good!

Tested tuner: check! (but the tuning did not like the chilled out workshop and was stuck. Simulating normal indor temp with a hairdryer made it move again)

Phono input: check! An old Link Wray record on the Lenco sounded really nice. The riaa in this thing means business.

So good old Goodmans is back from the dead! Now onto a proper cleanup and some new lamps.
Since I was paying more shipment than value of the transistors I also added on the order replacement capacitors for the big blue Erie supply reservoir caps (C144, C145).
Should I replace those or leave them in? The seem to be in good shape.
Any other preemptive actions to take to steer clear of future trouble?
I know a full recap probably would be advisable, but I m kind of a "if it ain't broken don't fix it"-guy

But all and all, I'm a happy camper right now.
And to you gentlemen who has adviced me in troubleshooting I owe a big thank you! ...and a pint or two if and when we cross paths!

Here's a video with "proof of life":

https://drive.google.com/folderview?...BmRmgzMFp2_R-B
Attached Thumbnails
Click image for larger version

Name:	IMG_20201019_192824.jpg
Views:	82
Size:	100.9 KB
ID:	218362  
CrazySwede is offline   Reply With Quote
Old 20th Oct 2020, 8:04 am   #32
tony brady
Pentode
 
Join Date: Mar 2014
Location: Peacehaven, East Sussex, UK.
Posts: 234
Default Re: Trying to revive a Goodmans One Ten receiver

that looks really nice in white and a good result to get it working!

as you have the supply capacitors you may as well change them anyway observing correct polarity when you fit the new ones. those Erie caps are 45 years old at least and they can often leak from the vent.

other than changing any callins ( black) electrolytics ( if fitted) I would not do a full recap. do not be tempted to change any capacitors in the tuner section anyway ( except electrolytics) otherwise you will have to re-align the RF & IF stages and that requires test gear

really if it's working ok leave it alone and enjoy it as it is
tony brady is offline   Reply With Quote
Old 20th Oct 2020, 10:43 am   #33
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 61
Default Re: Trying to revive a Goodmans One Ten receiver

Thanks for advice. Ok, think I'll just replace the big Erie's as a starter.
But not entirely sure about the polarity on these guys. Cannot find any clear markings (maybe hidden under the clamps?). But am I guessing right that the red wires are terminated on a positive lead and the black is negative?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20201020_123400_com.google.android.apps.photos~2.jpg
Views:	48
Size:	84.8 KB
ID:	218414  
CrazySwede is offline   Reply With Quote
Old 20th Oct 2020, 10:57 am   #34
tony brady
Pentode
 
Join Date: Mar 2014
Location: Peacehaven, East Sussex, UK.
Posts: 234
Default Re: Trying to revive a Goodmans One Ten receiver

one cap is for the positive supply and one for the negative. The red wire should be the positive supply. the black wire should be the negative. the tinned wire going from one cap to the other is the 0V.

there should be a red marking on the end of the cap painted on the rivet for the positive tag. be careful though as the cap on the negative line will have the red terminal connected to the 0V wire with the black wire connected to the -V terminal
tony brady is offline   Reply With Quote
Old 20th Oct 2020, 11:06 am   #35
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 61
Default Re: Trying to revive a Goodmans One Ten receiver

Ahh, so that what those red dots on the caps mean .
But as long as I match the red dotted tags on the old capacitors to positive marked tags on the new ones I am goood?
CrazySwede is offline   Reply With Quote
Old 20th Oct 2020, 11:08 am   #36
chriswood1900
Octode
 
Join Date: Jan 2007
Location: Bristol, UK.
Posts: 1,099
Default Re: Trying to revive a Goodmans One Ten receiver

In your picture the RH cap is red + pos green - neg, on the LH side Green is + and the black -, if I remember correctly Erie caps used a coloured dot on the terminal to denote polarity.
__________________
Chris Wood
BVWS Member
chriswood1900 is online now   Reply With Quote
Old 20th Oct 2020, 11:27 am   #37
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 61
Default Re: Trying to revive a Goodmans One Ten receiver

Thanks, I think I got it now
CrazySwede is offline   Reply With Quote
Old 20th Oct 2020, 2:30 pm   #38
turretslug
Dekatron
 
Join Date: Nov 2011
Location: Surrey, UK.
Posts: 3,731
Default Re: Trying to revive a Goodmans One Ten receiver

When you come to unsolder/remove the original capacitors, check with a voltmeter to make sure that they are absolutely discharged- depending on the circuit design and the condition of the capacitors, charge can linger for a surprisingly long time after switch off. Even if they only measure a few volts some time after disconnecting power, they can still deliver a hefty current spike if soldering iron or cutters short to something and that can kill semiconductors all over the place.

A painful and embarrassing lesson that sticks in the mind....
turretslug is offline   Reply With Quote
Old 20th Oct 2020, 2:58 pm   #39
CrazySwede
Tetrode
 
CrazySwede's Avatar
 
Join Date: Sep 2020
Location: Matfors, Sweden
Posts: 61
Default Re: Trying to revive a Goodmans One Ten receiver

Thank“s for the heads up about that. Will handle them and the iron with care.
CrazySwede is offline   Reply With Quote
Old 20th Oct 2020, 3:41 pm   #40
Nickthedentist
Dekatron
 
Nickthedentist's Avatar
 
Join Date: Jan 2005
Location: Oxford, UK.
Posts: 15,512
Default Re: Trying to revive a Goodmans One Ten receiver

Well done for getting this lovely thing going again. I wonder how many ended up in Sweden? Was Goodmans well known there in the 1970s and earlier? Note that the "Goodmans" name that appears on cheap Chinese TVs etc. nowadays is nothing to do with the original company.

I rescued one a few years ago as it was going to be dumped, having been replaced with a little Philips micro system. It worked very well, though the controls always tended to crackle. I gave it away in the end to somebody whose own one had been destroyed in a flood.

I also had a Module 80 receiver with inbuilt GL-75 turntable once, which I was very fond of. The One-Ten was often found with the later GL-85 built in: https://www.picclickimg.com/d/l400/p...GL-85-with.jpg

Or sometimes a Garrard:
https://www.picclickimg.com/d/l400/p...rrard-Zero.jpg

N.
Nickthedentist is offline   Reply With Quote
Reply

Thread Tools



All times are GMT. The time now is 12:09 pm.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright ©2002 - 2021, Paul Stenning.