UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio and TV Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > Specific Vintage Equipment > Vintage Television and Video

Notices

Vintage Television and Video Vintage television and video equipment, programmes, VCRs etc.

Reply
 
Thread Tools
Old 3rd May 2021, 8:59 am   #21
beery
Heptode
 
beery's Avatar
 
Join Date: Jun 2006
Location: Ware, Hertfordshire, UK.
Posts: 887
Default Re: Philips 663A combined radio/television 1948

Hi Matt,
great stuff so far.
I guess that given the set is on its third CRT, it is no surprise that the ECH35 valves don't want to play at VHF anymore.

Yes, your set has cleaned up very well, almost like new.
I once had a 1946 HMV 1804 that was like new (since sold to another BVWS member). On the rare occasions when sets turn up like that, it does make the restoration so much easier. Far fewer problems with noisy pots, valve holders and switches and also there is far less chance of failing transformers. Of course the cabinets are also much better if kept dry.
The set in question had the original Emiscope 3/4 that was also like new and the EHT transformer even worked! I've found some pictures of my actual set from before I restored it here :-
https://www.radiomuseum.org/r/hismasters_1804.html
The labels were fault dockets, stating that the owner was Mr Fox.

Anyway back to your set. Does it have a rubbr mask? If so then that has also survived well. 5:4 ratio 12" masks are hard to find.

Keep up the good work.

Cheers
Andy
beery is offline   Reply With Quote
Old 6th May 2021, 11:42 am   #22
matspar
Pentode
 
matspar's Avatar
 
Join Date: Aug 2009
Location: Portsmouth, Hampshire, UK.
Posts: 210
Default Re: Philips 663A combined radio/television 1948

Hi Andy, yes she does indeed have a 5:4 ratio rubber mask, which appears to have survived very well. Gorgeous HMV 1804, bet you wished you'd kept hold of that one!

The cabinet on the 663A will require a lot of work but I'm confident I can retain much of the original finish when the time comes.

I've got a short update on the 663A and a small bit of progress.

I'm still waiting for 4 new ECH35's to arrive to try in the line and frame osc, and the sound and vision freq changers. Postage seems incredibly slow down South lately!

In the meantime having had a bit of a play around I've discovered the timing issue of severe line foldover can be improved by experimenting with the values of R91 (3k) and C120 (0.005) across the line coils and eht flyback transformer. Halving both values to 1.5K and 0.0025 provides the best compromise as shown. Any increase in values will damp the EHT and focus is lost. I'm thinking this issue may be being caused in the first instance by a poor line oscillator ECH35 having an effect on the drive/frequency. Substituting the EL38 produces identical results.
The width control R138 will not behave as expected and instead tends to move the entire image to the left and begin to reintroduce the foldover.

There is still no audio but massive noise and disturbance on screen causing jitter, line pulling and instability. Definition is poor and focus is fully advanced and could be better. The 663A is also suffering from velocity modulation as the picture brightness will vary along the scan, however this was improved somewhat by giving the EF50 in the first RF stage a good wiggle in its socket. I'm undecided if a lot of these problems are being caused by the reciever end or the line limebase (or a combination of the two) hopefully I can start ruling things out once those new valves arrive.

There are a few circuit differences, most notably R43, which instead of being returned to deck is actually connected to the plus side of C119, which is a polarised capacitor (8uf electrolytic) in my set. This all looked totally original and wiring it to circuit causes total loss of sync.

Resistors are all within spec and all capacitors have been restuffed/replaced in the area of the circuit shown, except for three low value items C121(220pf) C99(180pf) & C101(12pf) which I've left alone for the time being.


Still a great deal to do!! as always any thoughts on these fault conditions most welcome and appreciated.
Attached Thumbnails
Click image for larger version

Name:	20210428_134436.jpg
Views:	116
Size:	41.7 KB
ID:	233423   Click image for larger version

Name:	182916651_10165330874535220_8160328273856503660_n.jpg
Views:	107
Size:	37.8 KB
ID:	233424   Click image for larger version

Name:	182350965_10165330874775220_289004305972237708_n.jpg
Views:	107
Size:	26.1 KB
ID:	233425   Click image for larger version

Name:	183096373_10165330889410220_4359884975308150058_n.jpg
Views:	93
Size:	72.9 KB
ID:	233426  
__________________
Matt

Last edited by matspar; 6th May 2021 at 11:55 am.
matspar is offline   Reply With Quote
Old 6th May 2021, 1:00 pm   #23
Heatercathodeshort
Dekatron
 
Heatercathodeshort's Avatar
 
Join Date: Jun 2005
Location: Warnham, West Sussex. 10 miles south of DORKING.
Posts: 8,057
Default Re: Philips 663A combined radio/television 1948

Can you reduce the line drive? It has the classic display of a chassis with the line drive variable cap screwed up hard! J.
Heatercathodeshort is offline   Reply With Quote
Old 6th May 2021, 1:06 pm   #24
Jac
Heptode
 
Jac's Avatar
 
Join Date: Jun 2006
Location: Eindhoven, Netherlands.
Posts: 553
Default Re: Philips 663A combined radio/television 1948

Shouldn't C119 be 25 F (-25V)?

Did you replace C96 - 97 - 98?
(sorry if you already have done so and I read over it)

Jac
Jac is offline   Reply With Quote
Old 6th May 2021, 1:30 pm   #25
matspar
Pentode
 
matspar's Avatar
 
Join Date: Aug 2009
Location: Portsmouth, Hampshire, UK.
Posts: 210
Default Re: Philips 663A combined radio/television 1948

Jac, yes it is indeed 25uf, quoted the wrong value from the circuit but the item fitted is correct. C96/97/98 are all visconols which I've restuffed with modern HV ceramic caps.

John I haven't discovered any line drive adjustment on this set (unless you know any differently!)
__________________
Matt
matspar is offline   Reply With Quote
Old 7th May 2021, 6:05 am   #26
Duke_Nukem
Octode
 
Duke_Nukem's Avatar
 
Join Date: Jan 2003
Location: Birmingham, West Midlands, UK.
Posts: 1,234
Default Re: Philips 663A combined radio/television 1948

Scraping the bottom of the barrel for ideas, but earlier pictures without the test card the raster looked evenly lit. Now the timebase is synchronised, its very non linear. What happens if you temporarily disconnect the sync and manually adjust timebase to display test card best as you can ?

Otherwise if its not R83/84/87 related then await the new ECH35.

I take it line hold and height pots aren't at one end of their range, which might mean they are masking the true cause ?

TTFN,
Jon
Duke_Nukem is offline   Reply With Quote
Old 7th May 2021, 7:47 am   #27
Heatercathodeshort
Dekatron
 
Heatercathodeshort's Avatar
 
Join Date: Jun 2005
Location: Warnham, West Sussex. 10 miles south of DORKING.
Posts: 8,057
Default Re: Philips 663A combined radio/television 1948

There does not appear to be a line drive adjustment on this model. Just as an experiment try connecting a small value capacitor around 200pf from the junction of R86 and C100.

The line output transformers were very unreliable in this model if past history is correct but they normally break down completely. I don't think yours has that problem. John.
Heatercathodeshort is offline   Reply With Quote
Old 11th May 2021, 1:07 pm   #28
matspar
Pentode
 
matspar's Avatar
 
Join Date: Aug 2009
Location: Portsmouth, Hampshire, UK.
Posts: 210
Default Re: Philips 663A combined radio/television 1948

I had a big breakthrough followed by a bit of a setback, but hopefully only a minor one.

The new ECH35's arrived and I began by replacing the suspect ones in the line and frame oscillator. Afterwards this produced a cogged but linear test card, with no trace of the previous velocity modulation and a massive improvement to the foldover that existed. EHT and focus was vastly improved also, showing 7.5kv on the meter.

Moving into the sync-seperator the cogging disappeared after replacing a 0.004uf coupling cap and a 75uf decoupling electrolytic, leaving a very respectable picture.
This was sadly short lived though and the width suddenly shot in leaving a narrow 3" raster. EHT is being damped to around 4kv.

HT has risen slightly, the line output valve (EL38) is slightly running into grid current. Examining the line drive waveform from the grid side of R86 is showing a sawtooth with a bit of a flat top.

I think I can rule out valve trouble as substituting the EL38 and even putting the old ECH35's back in are producing the same results.
I originally suspected a problem with the EHT doubler arrangement as such as failing HVR2's. EHT regulation was a bit poor when the Philips was working causing the picture to bloom when advancing the brightness. Could this be a bit of a red herring though?

The EHT transformer doesn't appear to be stressed and is running cool, so I'm hoping this isn't the culprit. Previously the line hold and width pots required critical adjustment. Line coils and componentry read ok.

Suspicion is now falling on C101 (12pf) along with C99 & C121. All low values which I don't have replacements for, so some are on order. Everything else in this area has been checked and/or replaced.

Would anyone tend to agree here?! bit of an unusual one.
Attached Thumbnails
Click image for larger version

Name:	185373921_10165351442055220_433874472476082084_n.jpg
Views:	94
Size:	44.8 KB
ID:	233763   Click image for larger version

Name:	185169002_10165351442445220_2215632861335131136_n.jpg
Views:	94
Size:	22.1 KB
ID:	233764   Click image for larger version

Name:	185531048_10165351442810220_8205556651015665724_n.jpg
Views:	79
Size:	80.9 KB
ID:	233765  
__________________
Matt

Last edited by matspar; 11th May 2021 at 1:23 pm.
matspar is offline   Reply With Quote
Old 11th May 2021, 1:18 pm   #29
matspar
Pentode
 
matspar's Avatar
 
Join Date: Aug 2009
Location: Portsmouth, Hampshire, UK.
Posts: 210
Default Re: Philips 663A combined radio/television 1948

Line timebase circuit
Attached Thumbnails
Click image for larger version

Name:	183096373_10165330889410220_4359884975308150058_n.jpg
Views:	52
Size:	72.9 KB
ID:	233768  
__________________
Matt
matspar is offline   Reply With Quote
Old 15th May 2021, 10:47 am   #30
beery
Heptode
 
beery's Avatar
 
Join Date: Jun 2006
Location: Ware, Hertfordshire, UK.
Posts: 887
Default Re: Philips 663A combined radio/television 1948

Quote:
Originally Posted by matspar View Post
Would anyone tend to agree here?! bit of an unusual one.
I hate to rain on your parade Matt, but I would be pretty sure that the line output transformer has shorted turns. I'd like to be proven wrong, but do be prepared to send off the transformer for rewinding. One might hope that it was all caused by the breaking down of heater supplies to the EHT doubling rectifiers, probably not that, but there is no harm in checking that with some silicon EHT diodes.

For the benefit of people who are not used to such early sets... Line collapse is a symptom that you won't see with a conventional combined line output and EHT transformer. We only see the symptom in this set because the rectifiers in the EHT voltage doubler do not have their heaters powered by the line output transformer. Mains EHT sets can also display line collapse, something I have unfortunately come across myself.

Cheers
Andy
beery is offline   Reply With Quote
Old 17th May 2021, 1:14 pm   #31
matspar
Pentode
 
matspar's Avatar
 
Join Date: Aug 2009
Location: Portsmouth, Hampshire, UK.
Posts: 210
Default Re: Philips 663A combined radio/television 1948

Thanks Andy,

I have today replaced the last few capacitors in the line oscillator which I didn't previously have replacements for but no improvements were forthcoming and I'm still seeing the narrow raster.
I disconnected the scan coils temporarily to see if this would produce any more EHT, checked their continuity again and made sure their tag connections weren't dry jointed but again no change. Similarily replacing the pair of HVR2's and re-checking the newly restuffed visconols didn't throw up any faults.
Running the set with the EL38 removed will produce a perfect sawtooth (line drive) waveform but re-inserting it will then flatten the top.
DC resistances of the line transformer are very close to what is quoted in the Philips manual.
Occasionally when powering up from cold a full scan is visible for around 10-20 seconds which will then collapse.
So by the process of elimination it would seem that the flyback transformer is really the only thing left now, could it have intermittent shorted turn(s)?!

I will now explore if this can be rewound as I'm not going to give up on this beauty. The transformer is in a small square pitch filled box, so no idea how it is wound or what it looks like.
Attached Thumbnails
Click image for larger version

Name:	lopt.jpg
Views:	37
Size:	71.8 KB
ID:	234262  
__________________
Matt

Last edited by matspar; 17th May 2021 at 1:22 pm.
matspar is offline   Reply With Quote
Old 17th May 2021, 3:17 pm   #32
Jac
Heptode
 
Jac's Avatar
 
Join Date: Jun 2006
Location: Eindhoven, Netherlands.
Posts: 553
Default Re: Philips 663A combined radio/television 1948

I would check all other possibilities first.
The line output transformer (T5) could very well have multiple wave-wound windings!

My 383A, which basically is the same set without the radio section, had a replacement LOPT, and this looks like this:
Click image for larger version

Name:	2016-06-09 383A 76 LOT in.jpg
Views:	61
Size:	75.8 KB
ID:	234271

Jac
Jac is offline   Reply With Quote
Old 18th May 2021, 7:34 pm   #33
matspar
Pentode
 
matspar's Avatar
 
Join Date: Aug 2009
Location: Portsmouth, Hampshire, UK.
Posts: 210
Default Re: Philips 663A combined radio/television 1948

It's a very interesting transformer and highly likely to be wavewound. The one in mine is potted with either wax or pitch I suspect. It's now gone off for rewinding (would love to see this process) so I won't get to see what lurks within. Out of circuit the primary is reading low. 58R when a figure of 80R is quoted. The secondary (2.7R) is spot on. The scan only failed once full EHT had been reached during the restoration, so would suggest it simply couldn't cope with what was being asked of it!
Attached Thumbnails
Click image for larger version

Name:	187187763_10165381439690220_2652849146524600325_n.jpg
Views:	35
Size:	43.2 KB
ID:	234390  
__________________
Matt

Last edited by matspar; 18th May 2021 at 8:01 pm.
matspar is offline   Reply With Quote
Reply

Thread Tools



All times are GMT. The time now is 4:16 pm.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright ©2002 - 2021, Paul Stenning.