UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > Specific Vintage Equipment > Vintage Audio (record players, hi-fi etc)

Notices

Vintage Audio (record players, hi-fi etc) Amplifiers, speakers, gramophones and other audio equipment.

Reply
 
Thread Tools
Old 9th Jul 2019, 9:18 pm   #1
bbthree3
Diode
 
Join Date: Jul 2019
Location: Alpine, Utah, USA.
Posts: 1
Default Need Help Hitachi DA-1000 CD Player

I just purchased a Hitachi DA-1000 vertical CD player. I received it in good working order, the lights were bright, the automatic door opened and closed excellent, the volume buttons didn't work but I didn't think that was a big deal. However, when I plugged in the RCA audio cable to my receiver there was no sound. The CD was spinning and the time count was working but nothing could be heard. So I took it apart, gave it a good cleaning, put it back together and now the darn thing won't even turn on. I have triple checked over and over the connections, making sure everything is in place properly and still nothing. I really don't want to scrap this thing and I would appreciate any and all help with this machine.

Thanks
bbthree3 is offline   Reply With Quote
Reply

Thread Tools



All times are GMT +1. The time now is 12:17 am.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright ©2002 - 2019, Paul Stenning.