UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio and TV Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > Specific Vintage Equipment > Vintage Radio (domestic)

Notices

Vintage Radio (domestic) Domestic vintage radio (wireless) receivers only.

Reply
 
Thread Tools
Old 20th Feb 2021, 6:57 pm   #1
longneck90
Hexode
 
Join Date: Sep 2013
Location: Wembley, London, UK.
Posts: 327
Default Amplion HU610. Power problem.

Hello to all. I was hoping I might have some of the Forum Members thoughts on the following. A week or so, I enquired on this Forum about a barretter for this radio. A Forum Member pointed me in the right direction in order to procure a barretter. While I was waiting for it to come, I used a spare 210 Ohm resistor (probably 6 or 8 Watt) across the heater? pins of where the barretter would be. I powered the radio up, through the Variac and Lamp Limiter. At 120 Volts across mains into radio, the Lamp Limiter began to just start to glow. The radio was going well, with good sound. I left it on for about 45 minutes. The aforementioned resistor got quite hot, but didn't seem to be stressed. When the barretter came, I replaced the resistor with it. Now!!! When the voltage reached 145 Volts, the Lamp Limiter began to glow. The maximum volume now, was about half what it was with the resistor, and the sound was more woolly. I changed 'that' capacitor, but no difference. (in sound quality) Also; when I put Signal Generator on V1 cap (465 HZ) there is no output. Yet, when I connect SG to Arial lead, the signal is audible. I have substituted V1, but no change. I am also wondering, am I too sensitive about the Lamp Limiter 'glow' or should I power up some more and see what happens. I hope all this makes sense, and would be glad to read any comments. All the best. John.

Last edited by Cobaltblue; 20th Feb 2021 at 7:10 pm. Reason: Barretter
longneck90 is offline   Reply With Quote
Old 20th Feb 2021, 7:37 pm   #2
Herald1360
Dekatron
 
Herald1360's Avatar
 
Join Date: Feb 2007
Location: Leominster, Herefordshire, UK.
Posts: 15,283
Default Re: Amplion HU610. Power problem.

The barretter will act to a certain extent as a constant current limiter whereas the resistor will allow the set current to follow Ohm's law except for the current taken by any pentodes/tetrodes which are themselves fairly constant current devices.

Whether this accounts for "woolly" I don't know, but it could be interesting to compare HT volts vs heater chain volts for the resistor and barreter at similar ac supply voltages to the set.

Edit: Looked at the circuit, the barretter is only in the heater chain circuit, not the HT feed to get rectifier, so you could be getting usable heater chain current (and lamp limiter glow) at a lower HT voltage than with the resistor which could well have some effect.
__________________
....__________
....|____||__|__\_____
.=.| _---\__|__|_---_|.
.........O..Chris....O
Herald1360 is offline   Reply With Quote
Old 21st Feb 2021, 12:25 pm   #3
longneck90
Hexode
 
Join Date: Sep 2013
Location: Wembley, London, UK.
Posts: 327
Default Re: Amplion HU610. Power problem.

Hello to all. Thanks Herald1360 for that information. I'll keep trying. All the best. John.
longneck90 is offline   Reply With Quote
Old 21st Feb 2021, 8:02 pm   #4
Ed_Dinning
Dekatron
 
Join Date: Jan 2004
Location: Newcastle upon Tyne, Tyne & Wear, UK.
Posts: 6,725
Default Re: Amplion HU610. Power problem.

Hi John, the function of the Barretter is to stabilise the conditions on the valve heaters.
To ensure it is working correctly try measuring the AC voltage across one of the valves' heaters and compare it with the data book

Ed
Ed_Dinning is offline   Reply With Quote
Old 22nd Feb 2021, 8:36 pm   #5
longneck90
Hexode
 
Join Date: Sep 2013
Location: Wembley, London, UK.
Posts: 327
Default Re: Amplion HU610. Power problem.

Hello to all. Thanks Ed. I'll check the voltages on heater chain, and to V5. All the best. John.
longneck90 is offline   Reply With Quote
Old 23rd Feb 2021, 2:23 pm   #6
longneck90
Hexode
 
Join Date: Sep 2013
Location: Wembley, London, UK.
Posts: 327
Default Re: Amplion HU610. Power problem.

Hello to all. To Herald and Ed. Radio sorted. Radio happily going for 75 minutes with no issues. What I done was; I plugged it in directly to the mains voltage. Then, for the first time, the barretter illuminated, and so then I knew that was good news. Before, I must have been too sensitive about the Variac and the Lamp Limiter. Having the Lamp Limiter and Variac connected must have been preventing the barretter from operating properly. All the best. John.
longneck90 is offline   Reply With Quote
Old 23rd Feb 2021, 7:25 pm   #7
Ed_Dinning
Dekatron
 
Join Date: Jan 2004
Location: Newcastle upon Tyne, Tyne & Wear, UK.
Posts: 6,725
Default Re: Amplion HU610. Power problem.

Hi John, good to hear it is working again.
A barretter is similar to a constant current device and relies on both the temperature coefficient of the iron wire filament and the very high thermal conductivity of the hydrogen gas in the envelope. This draws more heat from the filament as it gets hotter and self regulates over a quite wide range

Ed
Ed_Dinning is offline   Reply With Quote
Reply

Thread Tools



All times are GMT. The time now is 5:50 am.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright ©2002 - 2021, Paul Stenning.