UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > Specific Vintage Equipment > Vintage Amateur and Military Radio

Notices

Vintage Amateur and Military Radio Amateur/military receivers and transmitters, morse, and any other related vintage comms equipment.

Reply
 
Thread Tools
Old 10th Aug 2019, 8:06 pm   #1
M3VUV51
Pentode
 
Join Date: Feb 2018
Location: Horncastle, Lincolnshire, UK.
Posts: 202
Default Kenwood TS-850

Is a Kenwood TS-850 too modern to mention on here?
M3VUV51 is offline   Reply With Quote
Old 11th Aug 2019, 12:13 pm   #2
M3VUV51
Pentode
 
Join Date: Feb 2018
Location: Horncastle, Lincolnshire, UK.
Posts: 202
Default Re: Kenwood TS-850

anyone?
M3VUV51 is offline   Reply With Quote
Old 11th Aug 2019, 12:53 pm   #3
AC/HL
Moderator
 
AC/HL's Avatar
 
Join Date: Nov 2003
Location: Heckmondwike, West Yorkshire, UK.
Posts: 7,350
Default Re: Kenwood TS-850

Well, it appears to be over 25 years old, what do you want to say about it?
__________________
Bill, BVWS member
AC/HL is offline   Reply With Quote
Old 11th Aug 2019, 1:02 pm   #4
HamishBoxer
Dekatron
 
HamishBoxer's Avatar
 
Join Date: Aug 2007
Location: W.Butterwick, near Doncaster UK.
Posts: 6,770
Default Re: Kenwood TS-850

Fire away!
__________________
G8JET BVWS Member and V.M.A.R.S
HamishBoxer is online now   Reply With Quote
Old 18th Aug 2019, 9:06 pm   #5
M3VUV51
Pentode
 
Join Date: Feb 2018
Location: Horncastle, Lincolnshire, UK.
Posts: 202
Default Re: Kenwood TS-850

well its been a while,but long story short,brought one of these from ebay supposedly fully working etc,due to not having an hf antenna up couldnt test it so gave it to a g3zpu to test,turns out it max tx power was 12 watts,turns out the pa drivers were shot,also caps on the car board,got a new replacement pa from the states,set the idle current etc,may out was 70 watts,i thought i would set the swr foldback as per the manual,as i started to adjust the pot,the output would drop to zero,sort of like drops off a cliff edge,ie no gradual reduction sort of all or nothing,is this normal?,ps never got more than 70watts out max on fm and cw.
M3VUV51 is offline   Reply With Quote
Old 18th Aug 2019, 9:08 pm   #6
M3VUV51
Pentode
 
Join Date: Feb 2018
Location: Horncastle, Lincolnshire, UK.
Posts: 202
Default Re: Kenwood TS-850

that was into a dummy load with new car board caps fitted also the decoder ic on the filterboard replaced.
M3VUV51 is offline   Reply With Quote
Old 18th Aug 2019, 10:22 pm   #7
g4aaw pete
Hexode
 
g4aaw pete's Avatar
 
Join Date: Jan 2008
Location: Maidstone, Kent, UK.
Posts: 426
Default Re: Kenwood TS-850

Mr Google shows rather a lot of resources for various issues with the TS850.
__________________
Regards
Pete
g4aaw pete is offline   Reply With Quote
Old 18th Aug 2019, 11:46 pm   #8
M3VUV51
Pentode
 
Join Date: Feb 2018
Location: Horncastle, Lincolnshire, UK.
Posts: 202
Default Re: Kenwood TS-850

ive searched but dont se anyting like my issue tho.
M3VUV51 is offline   Reply With Quote
Old 19th Aug 2019, 11:44 pm   #9
M3VUV51
Pentode
 
Join Date: Feb 2018
Location: Horncastle, Lincolnshire, UK.
Posts: 202
Default Re: Kenwood TS-850

my understanding was the output throttled back not drop suddenly to zero? is this right.
M3VUV51 is offline   Reply With Quote
Reply

Thread Tools



All times are GMT +1. The time now is 4:16 pm.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright ©2002 - 2019, Paul Stenning.