UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > Specific Vintage Equipment > Vintage Audio (record players, hi-fi etc)

Notices

Vintage Audio (record players, hi-fi etc) Amplifiers, speakers, gramophones and other audio equipment.

Reply
 
Thread Tools
Old 15th Apr 2019, 8:55 am   #1
1976saint
Triode
 
Join Date: Feb 2019
Location: Waterlooville, Hampshire, UK.
Posts: 16
Default Aiwa HT-DV90 Help (no power)

After the successful help/diagnosis and repair of my old AKAI AA-RL1 AMP (https://www.vintage-radio.net/forum/...d.php?t=154464) my next project is to get my old Awia HT-DV90 working again. I'd like to use it again as a CD-Player to go with my newly working AMP.

It had a problem firstly that it didn't read disks anymore but that was fine as I primarily used it for TV surround due in most part to it's dual OPTICAL Inputs!

Then one day it wouldn't power on. I put it in storage and a few years back but recently took the lid off and found that the FUSE F604 had blown.

So not being good at electronic circuit diagnostics (but handy with a soldering iron) I turn to you guys to once again help point me in the right direction as to where to start looking please.

I've attached the service manual (which I found free this time) and photos of the power PCB. Note the underside which look to be some kind of capacitor maybe which do not look great.

https://www.manualslib.com/download/...a-Ht-Dv90.html

Kind Regards
Paul
Attached Thumbnails
Click image for larger version

Name:	Awia-Pwr-PCB-Track-Side.jpg
Views:	129
Size:	90.3 KB
ID:	181365   Click image for larger version

Name:	Awia-Pwr-PCB-Comp-Side.jpg
Views:	117
Size:	46.4 KB
ID:	181366  
1976saint is offline   Reply With Quote
Old 15th Apr 2019, 5:31 pm   #2
Silvered_Mica
Tetrode
 
Silvered_Mica's Avatar
 
Join Date: Aug 2003
Location: Halesowen, West Midlands, UK
Posts: 92
Default Re: Aiwa HT-DV90 Help (no power)

Well if it's banging fuses start with the filter block and look for shorts or leakages, that’s the bit between the mains input CN61 and the rectifiers BD62-BD63.
Check the rectifiers as a diode might have gone short. Check the chopper FET Q234 for shorts leakage.
It's also possible that one of the controller IC's has failed IC57-IC66.
Check D662 and Q617 if these are having problems they could have destroyed IC66.

These are the first few checks I would do. Good luck
__________________
Trust Me, It's a Magic Iron (∩ ͡° ͜ʖ ͡°)⊃━☆゚. * ・ 。゚, 📻📺🦔📡
Silvered_Mica is offline   Reply With Quote
Old 15th Apr 2019, 6:09 pm   #3
Silvered_Mica
Tetrode
 
Silvered_Mica's Avatar
 
Join Date: Aug 2003
Location: Halesowen, West Midlands, UK
Posts: 92
Default Re: Aiwa HT-DV90 Help (no power)

Another thing I should have mentioned, if it's a glass fuse and it has gone all black your going to have to do some fault finding
but if the fuse has a small break in the wire you might be very lucky and just be able to change the fuse.
__________________
Trust Me, It's a Magic Iron (∩ ͡° ͜ʖ ͡°)⊃━☆゚. * ・ 。゚, 📻📺🦔📡
Silvered_Mica is offline   Reply With Quote
Old 15th Apr 2019, 9:05 pm   #4
paulsherwin
Moderator
 
paulsherwin's Avatar
 
Join Date: Jun 2003
Location: Oxford, UK
Posts: 17,826
Default Re: Aiwa HT-DV90 Help (no power)

If nothing has obviously gone bang or cooked then I would certainly try another fuse. They do degrade with time and eventually fail during the switchon surge.

If the new fuse blows immediately then you do indeed have a more significant fault, and the player is likely to be BER. It does look as if something has got very hot under the PCB, but the photo may be misleading.
paulsherwin is offline   Reply With Quote
Old 15th Apr 2019, 11:39 pm   #5
1976saint
Triode
 
Join Date: Feb 2019
Location: Waterlooville, Hampshire, UK.
Posts: 16
Default Re: Aiwa HT-DV90 Help (no power)

Thank you for the advice, I'll take look at the parts advised. The fuse was black (gone bang) unfortunately!
1976saint is offline   Reply With Quote
Old 16th Apr 2019, 7:29 am   #6
Diabolical Artificer
Dekatron
 
Diabolical Artificer's Avatar
 
Join Date: Jul 2009
Location: Sleaford, Lincs. UK.
Posts: 4,197
Default Re: Aiwa HT-DV90 Help (no power)

Are those two jumper wires on the underneath of the PCB factory or a bodge? Check them against the schematic.

What are the voltages the PSU supplies? It may be possible to find another SMPSU that will fit to save fixing this one, although of coarse the rest of the device will need checking for shorts before powering up with a new PSU.

Andy.
__________________
Curiosity hasn't killed this cat...so far.
Diabolical Artificer is offline   Reply With Quote
Old 16th Apr 2019, 8:21 am   #7
1976saint
Triode
 
Join Date: Feb 2019
Location: Waterlooville, Hampshire, UK.
Posts: 16
Default Re: Aiwa HT-DV90 Help (no power)

The two jumper wires underneath look to be a couple of components covered with a plastic sleeve. They have a bit of resistance when I put a meter over them. They are not on my schematic, the version of the HT-DV90 is the K variant possibly which could stand for UK (and would make sense)?

I guess there could be another SM around showing them but I've not come across any as yet.

Searching the web for this unit is also proving pretty elusive atm.

@paul , I think I might have tried a new fuse when I first looked at the problem but I can't remember as it was about a year or so ago. The blacken part of the board your referring to is melted black sleeve (but cover two unidentified components) it looks like and around the base of the big capacitor solder point. I'll take another pic for a better look-see.

Paul.
1976saint is offline   Reply With Quote
Old 16th Apr 2019, 9:24 am   #8
1976saint
Triode
 
Join Date: Feb 2019
Location: Waterlooville, Hampshire, UK.
Posts: 16
Default Re: Aiwa HT-DV90 Help (no power)

Photos of jumper bodge components, and burn marks attached.
Attached Thumbnails
Click image for larger version

Name:	Awia-Pwr-PCB-Track-Side2.jpg
Views:	77
Size:	82.5 KB
ID:	181407   Click image for larger version

Name:	Awia-Pwr-PCB-Track-Side3.jpg
Views:	82
Size:	92.2 KB
ID:	181408   Click image for larger version

Name:	Awia-Pwr-PCB-Track-Side4.jpg
Views:	76
Size:	66.9 KB
ID:	181409   Click image for larger version

Name:	Awia-Pwr-PCB-Track-Side5.jpg
Views:	66
Size:	46.2 KB
ID:	181410  
1976saint is offline   Reply With Quote
Old 16th Apr 2019, 10:13 am   #9
paulsherwin
Moderator
 
paulsherwin's Avatar
 
Join Date: Jun 2003
Location: Oxford, UK
Posts: 17,826
Default Re: Aiwa HT-DV90 Help (no power)

It could be that that is a factory modification made during the production run after some problem was identified. It's not uncommon to find components soldered onto the wrong side of a PCB. The work doesn't look very professional though.

I've no idea what the components are or whether they've overheated, but the third pic doesn't look good with what appears to be melted solder.
paulsherwin is offline   Reply With Quote
Old 16th Apr 2019, 11:44 pm   #10
ekjdm14
Hexode
 
Join Date: Feb 2019
Location: Congleton, Cheshire, UK.
Posts: 296
Default Re: Aiwa HT-DV90 Help (no power)

I'd agree it does look like things have got a bit hot there. I wonder if they were (underspecced) resistors that have been getting hot and going progressively lower in value/passing more current/getting hotter until they've reached a runaway situation and popped the fuse.

If the apparent heatshrink(?) could be removed and they are in fact resistors, and still readable, then I might lift them out of circuit and check their values.

The only other thing they look like to my mind, is small inductors that I've seen in a package similar where the bodies look to be covered in tubing like that. Doesn't look healthy though.
__________________
Dan.
ekjdm14 is offline   Reply With Quote
Old 17th Apr 2019, 1:18 am   #11
ben
Dekatron
 
ben's Avatar
 
Join Date: Aug 2006
Location: Madrid, Spain / Wirral, UK
Posts: 5,274
Default Re: Aiwa HT-DV90 Help (no power)

Looks like there's some glue there attaching those track side resistors which has turned conductive. Remove it all before attempting to power that up again.
__________________
Regards,
Ben.
ben is offline   Reply With Quote
Old 18th Apr 2019, 5:55 pm   #12
Silvered_Mica
Tetrode
 
Silvered_Mica's Avatar
 
Join Date: Aug 2003
Location: Halesowen, West Midlands, UK
Posts: 92
Default Re: Aiwa HT-DV90 Help (no power)

Hello,
When looking at the pictures posted I first thought they had put some avalanche protection diodes across the output
of the rectifiers but after enlarging the picture and putting my glasses on I can now see that they have paralleled the
outputs of the rectifiers, possibly via two low value resistors? I have not seen this done before, I imagine it's maybe
done to share the current as one rectifier is rated at 1 amp and the other is rated at 4 amps so maybe the one rectifier
was a bit borderline. Or maybe they need to share the reservoir capacitance, it's not clear
I don't see why it needs two rectifiers anyway, it obviously didn't work very well if they had to strap them together
after manufacture.

If that board burn between C653 and the link wire is a piece of track blown out then it's possible that IC67 has failed.
__________________
Trust Me, It's a Magic Iron (∩ ͡° ͜ʖ ͡°)⊃━☆゚. * ・ 。゚, 📻📺🦔📡
Silvered_Mica is offline   Reply With Quote
Old 28th Apr 2019, 12:24 am   #13
1976saint
Triode
 
Join Date: Feb 2019
Location: Waterlooville, Hampshire, UK.
Posts: 16
Default Re: Aiwa HT-DV90 Help (no power)

The two parts under the board are I discovered at 330 (orange orange black orange brown) ohm resistor (the big foreground mess in picture ...track side3.jpg) and the other a diode.
Both seem functional in that the diode is correctly responds with a value one way but not the other and the resistor is also giving a reading but I'll need to desolder one end to properly check.
1976saint is offline   Reply With Quote
Old 28th Apr 2019, 4:47 pm   #14
Chris55000
Heptode
 
Join Date: Aug 2007
Location: Walsall Wood, Aldridge, Walsall, UK.
Posts: 632
Default Re: Aiwa HT-DV90 Help (no power)

Hi!

Orange-Orange-Black-Orange-Brown is 330k ±1% tolerance - can you post close-up pictures of the components please - then I can issue a revised diagram sheet showing them & where they're connected please?

Chris Williams
__________________
It's an enigma, that's what it is! This thing's not fixed because it doesn't want to be fixed!
Chris55000 is offline   Reply With Quote
Old 28th Apr 2019, 6:02 pm   #15
Chris55000
Heptode
 
Join Date: Aug 2007
Location: Walsall Wood, Aldridge, Walsall, UK.
Posts: 632
Default Re: Aiwa HT-DV90 Help (no power)

Hi!

If you unsolder one end of each added component & remove the sleeving from each, I can identify what they are and complete my revision sheet, which I'll post for you, then I'll follow it up with fault-finding & repair advice for your unit!

Chris Williams
__________________
It's an enigma, that's what it is! This thing's not fixed because it doesn't want to be fixed!

Last edited by Chris55000; 28th Apr 2019 at 6:29 pm.
Chris55000 is offline   Reply With Quote
Old 28th Apr 2019, 6:45 pm   #16
ekjdm14
Hexode
 
Join Date: Feb 2019
Location: Congleton, Cheshire, UK.
Posts: 296
Default Re: Aiwa HT-DV90 Help (no power)

Quote:
Originally Posted by ben View Post
Looks like there's some glue there attaching those track side resistors which has turned conductive. Remove it all before attempting to power that up again.
It's clear that it's likely to be "brown circuit glue" now you've said it! Yes that gunk goes crispy and conductive over time (I believe speeded by heat) and needs to be carefully got out of there paying attention to not lift/break any traces underneath it. I'd be surprised if it passed enough current on it's own to cause the symptom here but it is probably at least partly to blame for whatever failure has occurred. (Especially if it's been bridging across that 1% tolerance resistor).
__________________
Dan.
ekjdm14 is offline   Reply With Quote
Old 30th Apr 2019, 5:21 pm   #17
1976saint
Triode
 
Join Date: Feb 2019
Location: Waterlooville, Hampshire, UK.
Posts: 16
Default Re: Aiwa HT-DV90 Help (no power)

Uploaded images - should be attached, thank you.
Attached Thumbnails
Click image for larger version

Name:	Diode.jpg
Views:	28
Size:	61.8 KB
ID:	182170   Click image for larger version

Name:	Resistor.jpg
Views:	27
Size:	48.9 KB
ID:	182171  
1976saint is offline   Reply With Quote
Old 30th Apr 2019, 7:55 pm   #18
1976saint
Triode
 
Join Date: Feb 2019
Location: Waterlooville, Hampshire, UK.
Posts: 16
Question Re: Aiwa HT-DV90 Help (no power)

I found time to solderer those parts (attached). Both fail to supply a reading on my meter! So previously there was resistance from somewhere else?
Attached Thumbnails
Click image for larger version

Name:	Diode_Resistor.jpg
Views:	31
Size:	93.0 KB
ID:	182181   Click image for larger version

Name:	Resistor_Diode.jpg
Views:	30
Size:	75.4 KB
ID:	182182  
1976saint is offline   Reply With Quote
Old 5th May 2019, 4:44 pm   #19
Silvered_Mica
Tetrode
 
Silvered_Mica's Avatar
 
Join Date: Aug 2003
Location: Halesowen, West Midlands, UK
Posts: 92
Default Re: Aiwa HT-DV90 Help (no power)

Could you give us the part number markings off the diode please?
__________________
Trust Me, It's a Magic Iron (∩ ͡° ͜ʖ ͡°)⊃━☆゚. * ・ 。゚, 📻📺🦔📡
Silvered_Mica is offline   Reply With Quote
Old 5th May 2019, 6:19 pm   #20
1976saint
Triode
 
Join Date: Feb 2019
Location: Waterlooville, Hampshire, UK.
Posts: 16
Default Re: Aiwa HT-DV90 Help (no power)

Hi numbes are IN4937 on the diode.
1976saint is offline   Reply With Quote
Reply

Thread Tools



All times are GMT +1. The time now is 3:51 pm.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright ©2002 - 2019, Paul Stenning.