UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > General Vintage Technology > Success Stories

Notices

Success Stories If you have successfully repaired or restored a piece of equipment, why not write up what you did and post details here. Particularly if it was interesting, unusual or challenging. PLEASE DO NOT POST REQUESTS FOR HELP HERE!

Reply
 
Thread Tools
Old 11th May 2018, 7:39 pm   #1
dave_n_t
Pentode
 
dave_n_t's Avatar
 
Join Date: Sep 2003
Location: Cheltenham, Gloucestershire, UK.
Posts: 111
Default Sky Queen Chassis

This is really only half a success story: I bought an Ever Ready Sky Queen at a recent Radiophile auction largely on impulse, because it had its own internal mains unit. On not-so-close inspection, it was clear that the case was completely shot: cracks in the plywood, delamination of same, chunks missing, extra holes drilled in it, and rexine ripped. Since I already have one nicely-restored Sky Queen, I consoled myself that this would afford some useful spares, at worst; or maybe the chassis could be rescued (as I have done before on a similarly poor Sky Baronet. The chassis are useful as quick valve test units: I prefer testing valves in sets, if possible, since that's the job they're eventually going to perform, anyway).

Before thinking about restoring the chassis, I tested the speaker, output transformer, and valves. All were OK, so it looked like a reasonable job to undertake.

Summary: things that I 'put right':

- restring the tuning drive
- wavechange/on/off switch clean and lube
- rewire HT on-off-on switch (had been bypassed)
- fix touching vanes on the tuning capacitor
- replace electrolytic: lost capacity
- replace decoupling caps - leaking
- replace 2 resistors - gone very high in value
- repair broken IF transformer
- IF re-aligned
- whole RF re-alignment
- valveholder making poor contact - cured
- new tuning pointer fashioned

Expansion on some of the above:

I prefer to use switch cleaner/lube from a 'pen' dispenser, where possible - but getting it into all the right places in a 4-pole 3-way switch isn't easy, so I resorted to the spray stuff.

I guess the poor contacts on the switch had led someone (quite a long time ago, by the look of the soldered joint) to by-pass the HT switch (or maybe it was a mod. made at the time the mains unit was fitted - there was no longer any battery plug, so it had to be powered from the mains).


The voltages on the valves seemed OK, but there was no radio activity, and I couldn't detect the oscillator working by holding a transistor radio nearby and running up and down the waveband. Checking the tuning cap, I found that each of the 2 gangs was shorted over part of its range. A slip of strong paper (the waxy backing paper from some sticky labels) soon unearthed that an outer vane in each case had been slightly twisted. A bit of careful bending sorted them both out.

The main (8uF) electrolytic had lost the majority of its capacity, and was so large that it blocked access to other components, so it was replaced with a new 10uF 100V working one - somewhat smaller!

There was still little activity, and my trusty old signal injector showed that,
whilst the DL96 was working reasonably well, the DAF96's triode wasn't doing a great deal. I tried to check the voltages, but of course the currents here are minute, and even my old valve (milli)voltmeter had a input resistance of just over 10 megohm, and this pulled the readings well down. So I checked the resistance of the anode resistor, and the screen grid resistor, which should be 1meg and 4.7meg respectively. They measured 2.5meg, and 7.5meg, so out they came, and in went a couple of new 1/4 or 1/8W pieces. The DAF96 now seemed to be doing something useful, so I turned to the waxies.

All the decouplers throughout (including the AVC decoupler) were leaky, so they were replaced with short-leaded polyester caps I'd recovered over many years during my 'transistor phase'. I built up a good routine: wire-wrap some solid core bare wire onto each leg, solder in place and trim; cover with thin gauge yellow heatshrink, and shrink. (Tip: wipe the iron tip before using it to shrink - the heat shrink seems to attract liquid solder). Soldering the replacements in was relatively easy, because they're smaller + so easier to fit in, and the wires are flexible(ish) and thinner than the originals, so easier to fit into the gaps in the solder tags on the valveholders. For the earths, I just soldered on top of the already-overloaded chassis tags.


None of the other resistors had shifted in any serious way, so were left alone.

The set now produced some quietish signs of life on MW, but there was clearly an intermittent valve contact on the DK96, and an alignment wouldn't come amiss.

I did a rough tweak of the trimmers, and was going to start off with the IF alignment when I noticed 2 things: the first IFT underneath tuning slug had been stuck in place by some white cement which seemed to be as hard as building cement; and the 2nd IFT's cylindrical former was 'loose'.


I'd have to leave the cemented slug in place; but that would then define the alignment for all the rest (and indeed it appeared to still be on 470kHz, with reasonable accuracy). The IFTs were (thankfully) the ones with screw-on shields so off came screening can #2. The coil former had been snapped off (relatively cleanly) at the base - and the windings were still soldered in place. I really wanted to keep those joints intact, since the old litz is quite a pain to solder afresh. Holding the two pieces in good contact was a bit tricky until I realised that the threading ran all the way across the break. Screwing down the slug to cross the join held the pieces reasonably well whilst a couple of blobs of araldite set.



Tip: the slug should have been greased (with vaseline, etc.) to stop any epoxy that seeped thru' fixing it in place for ever. I forgot!

But I remembered in time to dribble in some very fine lubricating oil (watchmakers') which, with proper trimming tools on both sides of the slug, extricated it. (To achieve this, I'd had completely to remove the top slug). Both slugs of the 2nd IFT now having been thoroughly displaced, an IF re-alignment was clearly needed. (But the araldite did effect a good repair).


The IF alignment went fine; for a change, I got the AVO 8 out and measured the AC voltage across the speaker on the 3V a.c. range. I was quite surprised to see (as others have said) that using the meter improves on alignment 'by ear' by a noticeable amount. I'm a Convert.

The RF was then realigned, according to the manual instructions; but, as a pre-cursor (pun!) I had to fashion a new pointer out of a length of thick copper wire and some more heatshrink.

Reception was now very good, with 4 LW stations during daylight available; and a dozen or so on MW (together with far more at night).



The final issue was the intermittent contact on the DK96. The valveholder wasn't the sort with the 'tuning fork' assembly that can sometimes snap; it was a slightly higher quality effort with each pin sitting in two halves of a cylinder. Tip: work out which pin is 'crackly' by inserting a few strands of 'stranded wire' before the valve. If this improves (if not cures) things, then you're on the right track. I found that there was but one pin causing the trouble, and judicious use of the point from a pair of compasses enabled me to bend back the two halves to the centre sufficiently. (I was prepared to do a single 'pin socket' graft, but thankfully didn't have to ).



I now have another working chassis, ideal for testing any battery valves I acquire; and for listening to, should the need arise

As ever, projects like this seem to fire up ideas for more things for me to do:
should I make a really high input impedance DC voltmeter - probably a mosfet source-follower, or FET-input Op-amp with an input divider chain of 10meg - or more - resistors? (OTOH, I've made do without one for quite some time....)


Three pictures are of the completed chassis underside
Click image for larger version

Name:	DSC00167.jpg
Views:	114
Size:	96.0 KB
ID:	162647,

a closeup of one replacement cap
Click image for larger version

Name:	DSC00168.jpg
Views:	103
Size:	70.8 KB
ID:	162648,

and the new pointer
Click image for larger version

Name:	DSC00170.jpg
Views:	102
Size:	26.2 KB
ID:	162649.
__________________
Dave Teague
dave_n_t is online now   Reply With Quote
Old 15th May 2018, 10:56 pm   #2
Phil G4SPZ
Dekatron
 
Phil G4SPZ's Avatar
 
Join Date: Apr 2005
Location: Bewdley, Worcestershire, UK.
Posts: 3,816
Default Re: Sky Queen Chassis

Well done, Dave. I have a Sky King (same chassis) which I also use for testing valves, as well as for listening to.

You're probably right that most of us get by without a high impedance voltmeter. This is largely because service sheet voltages are often quoted using a voltmeter of specified sensitivity, thus taking the meter loading into account. That, plus that high value resistors are known to drift high in value and are among the first things to be 'cold checked'.

I like restoring battery valve portables, and they are capable of good performance when properly aligned. Aligning using an output meter is definitely more accurate than doing it by ear!
__________________
Phil (BVWS / BVTVWM / NVM / GQRPC 2101)

Optimist [n]: Someone who is not aware of the full facts
Phil G4SPZ is offline   Reply With Quote
Reply

Thread Tools



All times are GMT +1. The time now is 6:27 pm.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright ©2002 - 2018, Paul Stenning.