UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > General Vintage Technology > Success Stories

Notices

Success Stories If you have successfully repaired or restored a piece of equipment, why not write up what you did and post details here. Particularly if it was interesting, unusual or challenging. PLEASE DO NOT POST REQUESTS FOR HELP HERE!

Reply
 
Thread Tools
Old 15th Feb 2020, 5:24 pm   #1
Hybrid tellies
Nonode
 
Hybrid tellies's Avatar
 
Join Date: Jan 2004
Location: Bristol, UK
Posts: 2,447
Default ITT/KB VC205 Repair

I have always admired these ITT/KB VC 200 single standard 625 UHF black and white televisions. They gave very good sharp pictures with a good stable black level and were more reliable than most of the black and white televisions of the day. The 20” and 24” tubes seemed to enjoy a longer life than most other black and white televisions of this era. In fact I don’t ever remember ever having to change a tube on one of these. A couple of features endeared them to me, first was there sensitivity thanks to the use of an IF pre-amp and most unusual was that the CRT is grid modulated, instead of the more normal cathode modulation.
My set uses the VC205 chassis, introduced in 1972, which is very similar to the original VC200 the main differences are a slightly modified and improved video output stage, changes to the layout of the PSU to stop the main board burning near the mains dropper resistors and an integrated circuit replaced discrete components in the 6Mhz intercarrier sound stage.

I saved this set from the scrap heap back in 1980. It came in with no sound and vision due to a failed LOPT. It looked as new cosmetically it was very clean inside with the original 20” Mullard tube fitted.
On replacing the LOPT I was rewarded by a stunning picture and it worked well for several years until an annoying intermittent fault developed. It would lose frame sync and the picture would go brighter with signs of arcing and a strong smell of ozone from the back of the set. Running the set in a darkened room I traced the arcing to the chassis across the mounting screw on the top of the LOPT. I cleared this fault by putting some insulating washers between the screw and the chassis. The set went on for a few more years before the LOPT failed again this time in style. There was a nasty sinister screeching noise with smoke and some sparks seen between the line windings of the LOPT and the core. By now it was the mid 1990’s and tracing a replacement LOPT was problematic. After trawling through the advertisements in the Television Magazine without success I called a company called Tidworth who said they did have two ITT VC 200 LOPT’s in stock one was being sent to someone in Zaire and the remaining one was mine. The replacement LOPT soon arrived and installed. This time instead of using the top mounting screw to secure the LOPT to the chassis I decided to do away with the screw mounting arrangement all together and bend the chassis bracket back out of harm’s way and secure the top of the LOPT assembly using some decent quality small cable ties. The line output stage sprang into life, all the voltages including the line drive, screen grid to the PL504, the two HT supplies, the boost voltage and the 20v LT line were spot on. This television then continued to run faultlessly for many years before it developed a frame output fault.

On switch on the frame height and linearity were perfect but as the set warmed and was running for about 20-30 minutes the frame would creep up from the bottom as well as the frame stretching at the top until it folded over and the frame hold would also go critical. Obviously a new PCL805 was tried and the cathode bias resistor and capacitor were changed to no avail. Voltage checks around the PCL805 revealed nothing they were correct before and during the fault with no variations seen. I suspected the thermistor on the scanning coils or the scanning coils themselves. As I was using this set as a monitor for my long-distance television or DX set up fed from my D100 tuner I decided to retire the set and replace it with a small multi standard colour tv. The ITT then lived on a shelf in the workshop which I would run up for 15-20 minutes every few months, this kept it going and the intention was to take another look at this fault when I had more time perhaps when or if I ever retire.

About 15 years later, a few weeks before Christmas, I joined in a conversation with our local radio station, BBC R Bristol, about the number of black and white TV licences issued by TV licencing and the question was asked about whether a black and white television can still work with today’s digital platforms. They seem to like my response to this question and asked if they could come and take a closer look. I agreed as I could at least show them my working BRC 1590 and BRC 980.

As I had a few weeks before the interview I decided to take another look at the frame fault on my ITT/KB VC205. I decided to take a few days off work as I needed to spend several hours moving things around in my small congested workshop just to make enough room to work on this set. I eventually got the back removed and started to do some tests. As before all the voltages around the PCL805 were correct before and when the fault was present and I was about to link out the thermistor on the scanning coils when I noticed that this thermistor, with a resistor was built into the scanning coil assembly, I could still link it out but felt a bit uneasy about this even though I was still convinced it was the scanning coils that were at fault. As the fault seemed to be thermal only showing when the set had been running a while, I borrowed a can of freezer from work and proceeded to delicately spray the components around the PCL805 valve when the fault showed itself. Spraying C71 resulted in the fault clearing then re appearing as the capacitor warmed up again. I repeated this several times until I was confident that the this was the faulty capacitor. Looking at the circuit diagram C71 is across the triode section of the PCL805 so I suspect it was upsetting the oscillator section of this circuit. I sourced some replacement 0.022uf 1Kv working capacitors from RS and ended up ordering rather more than I needed. After replacing C71 I had to reset the height and frame linearities which was a good sign. I could not get the linearities quite right with the two controls at the end of their range so I decided to change out the other three 0.022uf 1Kv working capacitors around the frame stage this time I was able to get perfect frame linearity. With bit of centring up using the magnets on the scanning coils, the reason for this goes back to the early 1980’s and involved a severe thunderstorm that upset the picture centring settings on black and white televisions and purity settings on colour televisions but that’s another storey, the picture is as good as its going to be. The condition of the original Mullard tube seems to be very good but these like their coloured cousins is not unusual for ITT with sharp focus right out to the corners of the screen. Just a point of interest that crosshatch pattern with the edge castellations is from a TV pattern generator, Teletest 2, that I bought at the last Royal Wootton Bassett BVWS event last December.

It is a nice tidy set but with all the problems encountered I think I have ended up with one from the Monday morning or Friday afternoon production run. I also have a ting of resentment towards this set as I was very short of space where I lived back in the 1980’s I had to make a choice of whether I kept this ITT or my excellent 19” Murphy V1914 using the RBM A640 chassis. Sadly I let the Murphy go and have regretted it ever since.
I don’t get a chance of doing as much repair work as I would like due to other time constraints but I really enjoyed the experience of fault finding again. I felt I was transported back to the 1970’s to a more pleasant and understandable time.
Attached Thumbnails
Click image for larger version

Name:	ITTKB VC205 6.jpg
Views:	113
Size:	38.1 KB
ID:	199035   Click image for larger version

Name:	ITTKB VC205 2.jpg
Views:	97
Size:	51.4 KB
ID:	199036   Click image for larger version

Name:	ITTKB VC205 1.jpg
Views:	100
Size:	59.2 KB
ID:	199037   Click image for larger version

Name:	ITTKB VC205 4.jpg
Views:	115
Size:	59.0 KB
ID:	199038   Click image for larger version

Name:	ITTKB VC205 5.jpg
Views:	103
Size:	41.1 KB
ID:	199039  

__________________
Simon
BVWS member

Last edited by Hybrid tellies; 15th Feb 2020 at 5:42 pm.
Hybrid tellies is offline   Reply With Quote
Old 15th Feb 2020, 6:10 pm   #2
PYE 405
Triode
 
Join Date: Dec 2009
Location: Chatteris, Cambridgeshire, UK.
Posts: 11
Default Re: ITT/KB VC205 Repair

A very interesting account of the history of the set. The capacitors you mention I believe are mixed dialectric. I had a few problems in my VC205 with the frame, but the condition was of a permanent nature until I replaced the capacitors.
I agree that they are excellent sets capable of the finest pictures.
Here is the story of mine...
https://www.radios-tv.co.uk/communit...tvs/itt-vc200/
__________________
Andrew
PYE 405 is offline   Reply With Quote
Old 16th Feb 2020, 1:16 pm   #3
slidertogrid
Octode
 
Join Date: Apr 2005
Location: Peterborough, Cambridgeshire, UK.
Posts: 1,010
Default Re: ITT/KB VC205 Repair

A very good write up ! it is nice to see one of these sets saved and preserved .
It makes me feel very old though! That these sets are now vintage and collectable!
I serviced many of these at my first Job in 1977. The firm I worked for used these and the PYE single standards almost exclusively for Mono Rentals.
Most of the dual standard mono sets had gone as there was good supply of single standards sets coming back in due to customers changing over to colour.
They still had a lot of mono rentals out in late 1980 when I left.
The Pye sets were ok but the VC200 series were better, they worked well were very reliable and certainly had a long life!
Rich.
slidertogrid is offline   Reply With Quote
Old 18th Feb 2020, 12:47 am   #4
1100 man
Octode
 
1100 man's Avatar
 
Join Date: Apr 2016
Location: Ventnor, Isle of Wight, & Great Dunmow, Essex, UK.
Posts: 1,125
Default Re: ITT/KB VC205 Repair

Quote:

I saved this set from the scrap heap back in 1980
Strewth, that's some gestation period in the 'round to it' pile! I'd not long been at secondary school then and was just finding my feet in the world of TV repairs. We still had B&W TV (in fact a Sobell 1000!) and were still a year away from colour in the shape of a Pye G11!

Several KB sets came my way at the time, most handwired, but I definitely remember the VC205 with that row of resistors at the top- I think I may have repaired one for a friend at school.

Looks like another set I need to look out for:- it would double my collection of KB sets!

I see your 'Teletest 2' has the same fault as mine- very noticeable once you are aware of it. The castellations at the top & bottom are offset from the grid. It doesn't reset properly at power on. Switch it on half a dozen times and eventually the white rectangles will end up where they should be- sitting between two vertical lines rather than straddling one line! I bet you didn't know that!!

Excellent write up by the way- most enjoyable!
All the best
Nick
1100 man is offline   Reply With Quote
Old 21st Feb 2020, 12:35 pm   #5
Hybrid tellies
Nonode
 
Hybrid tellies's Avatar
 
Join Date: Jan 2004
Location: Bristol, UK
Posts: 2,447
Default Re: ITT/KB VC205 Repair

Thanks for the kind comments. I can remember the VC200's from my days of living in Cornwall when they came out new. The picture on them seemed much better than most other black and white televisions at the time. I have always been a big fan of the ITT/KB hand wired dual standard black and white televisions. I saw them in action on both systems in Cornwall and repaired a lot of these for friends and family a few years later as part of my training.
Our last black and white 20" rental TV was I believe a Pye 169 single standard 625 set with the mechanical four push button tuner. I think it was the TV60. Looked very smart and modern and the picture was very good. The good black level was something that took a while to get used to as all our previous tellies were dual standard black and white sets.
I did not notice that fault with my Teletest 2 tuner but I will check this out sometime. My to do pile is now full I just need to retire so I can spend some quality time bringing some of these tellies and radios to life.
__________________
Simon
BVWS member
Hybrid tellies is offline   Reply With Quote
Reply

Thread Tools



All times are GMT +1. The time now is 6:38 am.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright ©2002 - 2020, Paul Stenning.