UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > General Vintage Technology > Success Stories

Notices

Success Stories If you have successfully repaired or restored a piece of equipment, why not write up what you did and post details here. Particularly if it was interesting, unusual or challenging. PLEASE DO NOT POST REQUESTS FOR HELP HERE!

Closed Thread
 
Thread Tools
Old 31st Mar 2014, 8:41 pm   #1
8 Tracker
Pentode
 
8 Tracker's Avatar
 
Join Date: Jul 2009
Location: Mablethorpe, Lincolnshire, UK.
Posts: 225
Default The Tek 7D20 saga

I’m a glutton for punishment. I’m also a fan of lost causes (probably why I collect 8-tracks and Beta videos). So when I was offered a Tektronix 7D20 programmable digitiser plugin, I couldn’t resist. “Going cheap” said the man. It was as well. “Too cheap” thought I, but I got it anyway. When I got it home, I had a quick shifty inside. Nothing too dramatic to be seen in there, though I did see that the front panel ribbon cable had been disconnected. Nothing else amiss. So I took the plunge and shoved it into my 7623A mainframe and poked the power button. The ‘scope powered up, the 7D20 did not. Nothing. No lights, no screen display, just blankness. I knew it was too good to be true. I suddenly wondered if I had killed the ‘scope, but a quick check with conventional plugins revealed all was well.

“So,” I thought, “It must be power supply troubles if it’s totally dead.” After working out how to get the thing apart (remember this is Tektronix gear and I hadn’t seen one in the flesh before) I pulled out the power supply card and consulted the freshly printed drawing. A “chopper upper” supply, which takes the ‘scopes +-15 and turns it into +-5. I changed a coupled of dodgy-looking electrolytics and then powered the card up on the bench, using an external supply. The -5v was a bit low, at -6, but apart from that everything seemed alright. There is a 100 ohm resistor shunting the series regulator on the -ve side, so without load the supply gets pulled down by this. Everything else OK, so the unit went back into the ‘scope and on went the power. This time, all the front panel lights came on. But that was all. The lights stayed on, there was no display, but at least that was better than before.

So not totally dead any more, but near to it. Where to start? The manual mentioned tests to be done if the front panel was non-responsive, but it seemed to assume the thing was otherwise OK. I decided to have a probe around the processor card to see if any address lines were stuck. This was not easy, as I had no extension fixtures, so everything needed to be done with the unit in the ‘scope. By taking the sides off the mainframe and the 7D20, there was room enough to connect a probe down in the bowels of the plugin before carefully sliding it into the mainframe and passing the probe cable through the side. I soon found out why the thing was non-responsive, there was no activity on any of the address lines that I checked. This was not good. Out came the processor card and with a couple of wires soldered onto test points, I managed to power the card on the bench. There was no activity anywhere on the card. Nothing. This particular 6809 processor has internal clock circuitry and just needs an external crystal. Even these lines were dead. I began to fear the worst, but put things on hold while a replacement processor arrived from eBay. While I was waiting, I looked at all the EPROMs with my trusty BBC model B based programmer. They all seemed to contain valid data, I could even make out certain words in the listing. So not everything on the card had been fried. I made copies of them all, just in case

Luckily for me, all the ICs on this card were socketed. It was like the Tek engineers had seen trouble ahead. When the processor arrived I wasted no time in plugging it in and firing up the board. My efforts were rewarded with activity on all the data and address lines. The thing was trying to actually do something. Crunch time. I put the card back into the plugin and tried firing up in the ‘scope. It worked! Front panel lights flashed and relays chattered as it went through its’ extensive self-test routine. At the end, I was presented with a display on the screen. It was only failing 8 (of 63) self-tests. Not bad.

After a play with the controls I discovered channel 2 seemed OK, but channel 1 was off the top of the screen somewhere. Most of the test failures were to do with channel 1. A clean of the input attenuator relays cleared a couple test failures and brought the total down to 6. Channel 1 still refused to put in an appearance. I started probing. This was a slow business, as it had to be done like before, with the unit in the mainframe.

However, the input card is at the extreme left, so with the ‘scope on its’ side I could probe without having to take the plugin out each time. The signal disappeared into one of the famous Tek custom ICs, which I was a little nervous about, but luckily emerged unscathed at the other side. After two more transistor stages, the signal was supposed to go off the board, except that in this case, it didn’t. The signal was getting lost after the last transistor. A tiny coil (about 5mm dia) was the culprit, one wire becoming detached from the board. After a re-solder, more fails disappeared and channel 1 finally showed itself on the screen.

Home straight now. Channel 1 would not move down below the bottom of the screen and when displaying a signal, the amplitude would decrease as the trace was moved towards the bottom. After yet more probing, I found something not quite right around the four transistors after the IC. They were so close together and so close to the board that individual testing was impossible, so I picked one at random and de-soldered it. I got some very strange readings with the meter, so found a near-substitute and soldered in. Were any of the others duff or had I been lucky and picked the right one first time? Only one way to find out. This time when I fired up I was rewarded by that most elusive “Selftest pass” message. I breathed a sigh of relief and rewarded myself with a small bar of chocolate. This had been an epic battle.

The next challenge? A 7603R mainframe with a great big screen so I can see the 7D20 display without squinting. The mainframe was bought as faulty. Like I said, I’m a glutton for punishment. Wish me luck..............
Attached Thumbnails
Click image for larger version

Name:	Scopeside.jpg
Views:	213
Size:	100.0 KB
ID:	90919   Click image for larger version

Name:	Unit.jpg
Views:	202
Size:	111.7 KB
ID:	90920   Click image for larger version

Name:	Working1.jpg
Views:	273
Size:	57.9 KB
ID:	90921   Click image for larger version

Name:	Working2.jpg
Views:	262
Size:	105.5 KB
ID:	90922   Click image for larger version

Name:	Scopeside 2.jpg
Views:	234
Size:	116.8 KB
ID:	90923  

__________________
Nobody's perfect. I'm a nobody. Therefore I'm perfect!
8 Tracker is offline  
Old 31st Mar 2014, 8:52 pm   #2
cmjones01
Octode
 
Join Date: Oct 2008
Location: Warsaw, Poland and Cambridge, UK
Posts: 1,912
Default Re: The Tek 7D20 saga

Well done! That's a nice repair. I think the 7D20 is notorious for RAM failures, so you were unlucky (or lucky) to get a smattering of other problems.

Chris
__________________
What's going on in the workshop? http://martin-jones.com/
cmjones01 is offline  
Old 1st Apr 2014, 9:16 am   #3
Andrew2
Octode
 
Join Date: Mar 2010
Location: Dukinfield, Cheshire, UK.
Posts: 1,488
Default Re: The Tek 7D20 saga

Wow, a gold star for perseverance! And what a nice scope.
__________________
Andy G1HBE.
Andrew2 is offline  
Old 1st Apr 2014, 6:04 pm   #4
PJL
Dekatron
 
Join Date: Sep 2005
Location: Seaford, East Sussex, UK.
Posts: 4,221
Default Re: The Tek 7D20 saga

Congratulations! It's fantastically rewarding to diagnose and fix what looks to be a lost cause. Interesting that it had multiple faults. Maybe it soldiered on without channel 1 for a while...or did the faulty caps cause the other failures.
PJL is offline  
Old 1st Apr 2014, 7:19 pm   #5
8 Tracker
Pentode
 
8 Tracker's Avatar
 
Join Date: Jul 2009
Location: Mablethorpe, Lincolnshire, UK.
Posts: 225
Default Re: The Tek 7D20 saga

It certainly looked like a lost cause to start with. I am still wondering what could totally kill a microprocessor, while leaving the other components on the board intact.

I had heard about various RAM failures. Fingers crossed mine stays OK. There are several parts in there that are totally unobtainium.

While it is not going to set the world of digital scopes alight in terms of performance, I am finding it very useful. So easy to set up, pre-trigger and instant storage at the push of a button. The beauty of this system is that I can just swap the plugins over and I am back to good old analogue again. The best of both worlds.

Mark.
__________________
Nobody's perfect. I'm a nobody. Therefore I'm perfect!
8 Tracker is offline  
Old 1st Apr 2014, 11:08 pm   #6
Radio Wrangler
Dekatron
 
Radio Wrangler's Avatar
 
Join Date: Mar 2012
Location: Fife, Scotland, UK.
Posts: 12,495
Default Re: The Tek 7D20 saga

Some periods of IC manufacturer left ICs vulnerable to corrosion from humidity ingress. The water content leached phosphorus out of the glass passivation layer and made weak phosphoric acid which attacked aluminium metal layers. This progressed if chips were kept in storage, and also attacked CMOS particularly because it ran so cool. Good hot TTL and ECL ran hot enough to drive moisture out.

It may have fallen over without external help.

David
__________________
Can't afford the volcanic island yet, but the plans for my monorail and the goons' uniforms are done
Radio Wrangler is online now  
Closed Thread

Thread Tools



All times are GMT +1. The time now is 7:57 am.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright ©2002 - 2019, Paul Stenning.