UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio and TV Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > Specific Vintage Equipment > Vintage Television and Video

Notices

Vintage Television and Video Vintage television and video equipment, programmes, VCRs etc.

Reply
 
Thread Tools
Old 14th May 2021, 7:29 am   #1
marsbar
Triode
 
Join Date: Apr 2011
Location: Stavanger, Norway .
Posts: 47
Default Bang Olufsen 25" hissing static sound at all times L and R

My Beovision LX2800 is working fine.

So I picked up another TV as spare.
Ad was weak, did not state the model.

LX2502
TV is 25", and remote differs slightly on layout but most essential functions remain.

I have ordered new loudspeakers as rubber ring was rotten.

But testing the 25" tody there is a problem: Picture seems fine, but there is a large hiss on the loudspeakers at all time, no matter what you press or the volume is at.

The hiss is like a coarse FM radio static sound.

Anybody with a hint where to start? Does the audio section have its own power supply?

The owner said it worked fine 5 years ago before storage.

Looks like the psu have been repaired at some stage replacing a transistor, like BC548. (Because it have long legs)

Othervise TV look lovely, but difficult for me to find more parts tv in my district.

Hissing is loudly present L and R nor what I do.
Sound level does not affect it, its loud at all times regardless of source. But video source on makes it hiss aslightly different.

Where to start?
Attached Thumbnails
Click image for larger version

Name:	IMG_20210514_092718.jpg
Views:	146
Size:	74.6 KB
ID:	233983  
marsbar is offline   Reply With Quote
Old 14th May 2021, 9:49 am   #2
agardiner
Hexode
 
Join Date: Sep 2020
Location: Thetford, Norfolk, UK.
Posts: 340
Default Re: Bang Olufsen 25" hissing static sound at all times L and R

Apart from the hiss, does the set produce appropriate audio?
agardiner is offline   Reply With Quote
Old 14th May 2021, 10:06 am   #3
paulsherwin
Moderator
 
paulsherwin's Avatar
 
Join Date: Jun 2003
Location: Oxford, UK
Posts: 21,701
Default Re: Bang Olufsen 25" hissing static sound at all times L and R

It appears to be full of the dreaded Lockfits. Change any BC148/9s and BC158/9s to BC549s / BC559s.
paulsherwin is offline   Reply With Quote
Old 14th May 2021, 10:09 am   #4
marsbar
Triode
 
Join Date: Apr 2011
Location: Stavanger, Norway .
Posts: 47
Default Re: Bang Olufsen 25" hissing static sound at all times L and R

Nothing. Maybe a hint of crackling if u turn the volume up.

The fault is strange, like there is a noise generator
For white noise permanently connected at a fixed level.

I have the circuit diagram for the audio 2800.

I suspect the ekectronic mux to be damaged, the circuit that swaps inputs.

A solution could be to hard wire the audio ic directly to the scart, but then you have no audio volume control.

So fault could be in volume regulator?

I am going to try a cleanup of boards first. Looks fine but who knows.
marsbar is offline   Reply With Quote
Old 14th May 2021, 10:40 am   #5
bill knox
Pentode
 
Join Date: Mar 2011
Location: Wilstead, Bedfordshire, UK.
Posts: 209
Default Re: Bang Olufsen 25" hissing static sound at all times L and R

Hi

Your original TV was that bought in Norway and the same for the new one,

I maybe wrong but the the intercarrier sound on the continent is different from UK, I believe the continent works on 5.5 Mhz and over here it works on 6 Mhz

I don't know if the inter carrier works with an Xtal filter if it does then by changing that you may get a bit further on, in the past ( a long time ago ) I have managed to adjust the last sound coil .

You could possibly check by off tuning off the channel you are trying to watch and see if there is any sound at all, you will not be able to get the sound and vision together but it would be nice to see if there is any sound at all.

Did you say that the "hissing " is still present at all levels of the volume control, even when it is at minimum?

Regards

Bill
bill knox is offline   Reply With Quote
Old 14th May 2021, 6:01 pm   #6
marsbar
Triode
 
Join Date: Apr 2011
Location: Stavanger, Norway .
Posts: 47
Default Re: Bang Olufsen 25" hissing static sound at all times L and R

The hissing is present at all time.
If you look at static its designed to be muted.
If you look at AUX video in, same thing...
No response if you adjust volume up down
Hissing all the time
If you disconnect one speaker hard wire hissing alters, fades, then rises again...
marsbar is offline   Reply With Quote
Old 15th May 2021, 8:08 pm   #7
marsbar
Triode
 
Join Date: Apr 2011
Location: Stavanger, Norway .
Posts: 47
Default Re: Bang Olufsen 25" hissing static sound at all times L and R

Where are these likely transistors located?
marsbar is offline   Reply With Quote
Old 15th May 2021, 8:34 pm   #8
Maarten
Dekatron
 
Join Date: Dec 2007
Location: Haarlem, Netherlands
Posts: 3,217
Default Re: Bang Olufsen 25" hissing static sound at all times L and R

The photo doesn't show any lockfits, also they would not have been used in a 1980's model, neither should they always be replaced on sight (in any set made outside the UK?)
Maarten is online now   Reply With Quote
Old 17th May 2021, 9:45 am   #9
Max Ripple
Pentode
 
Join Date: Oct 2016
Location: near Coventry, West Midlands, UK.
Posts: 134
Default Re: Bang Olufsen 25" hissing static sound at all times L and R

These are lovely telly's,capable of very good performance even now!
From your description of the problem as not being affected by volume settings,it seems as though the output amplifier etc is at fault.
It's a stereo tv,so there are two seperate output amplifier chips (TD2040?)and a processor chip common to both channels.Any of these chips could be noisy,and it's useful to see if temperature affects the noise.
Do you have some freezer spray?If you apply this to the chips in turn and it reduces or increases the noise,then there is the problem?
I have the service manual too if you need more tech info.
Nick
Max Ripple is offline   Reply With Quote
Old 17th May 2021, 5:51 pm   #10
marsbar
Triode
 
Join Date: Apr 2011
Location: Stavanger, Norway .
Posts: 47
Default Re: Bang Olufsen 25" hissing static sound at all times L and R

The set was stored unused for 5 years. I have the manual for a 28" quite similar. Picture looks fine, but not tried with RGB yet that should pimp some color into that CRT. Loudspeaker rim broken, so new bass elements 3" 8 ohm ordered.

Sound is easy though, will solder out some c's to break signal path. I suspect mixer after volume adjustment...
marsbar is offline   Reply With Quote
Old 18th May 2021, 7:16 pm   #11
McMurdo
Dekatron
 
McMurdo's Avatar
 
Join Date: Jun 2009
Location: Staffordshire Moorlands, UK.
Posts: 4,327
Default Re: Bang Olufsen 25" hissing static sound at all times L and R

I remember a similar stock fault on a Sanyo caused by an open circuit smoothing capacitor on a LOPT or SMPSU-derived rail, allowing the switching noise to get to the amplifier. It just sounded like loud, white noise.
__________________
Kevin
McMurdo is offline   Reply With Quote
Old 18th May 2021, 8:50 pm   #12
John123
Heptode
 
Join Date: Jan 2007
Location: Luton, Bedfordshire, UK.
Posts: 736
Default Re: Bang Olufsen 25" hissing static sound at all times L and R

Maybe have a go at tuning in the tuner to a blank screen from an RF modulator/ VCR (VCR set to its A/V channel). Perhaps that might rule-out the tuner/ IF stage as a source of the noise?

These sets often feature a plethora of DIN A/V, Tape, Amplifier in's and out's. Try tapping the audio directly from one of these (or routing audio through them). It should be possible to tap the audio from a tuned RF channel from one of theses sockets (or the SCART). That would be quite telling in itself, perhaps narrowing things down to the power amplifier stages.

Reseat all board interconnects and edge-type connectors by plugging/ unplugging several times. Inspect solder-side for dry joints.
__________________
Regards,
John
John123 is offline   Reply With Quote
Old 19th May 2021, 1:29 am   #13
marsbar
Triode
 
Join Date: Apr 2011
Location: Stavanger, Norway .
Posts: 47
Default Re: Bang Olufsen 25" hissing static sound at all times L and R

It looks like this will be a winter project.

I have a similar 28", same circuit boards.

This TV is 25.

AUX in: Hissing sound both channels.
A correct BO would anyway have muted hissing on a blank snow screen.

But I noticed when the tv was cold, hissing was low.
Then it increased slightly as tv got hotter.

Hissing is equal in L and R. Static FM noise,
Blank station in FM band.

I am foing to use the schematic and solder out a c leg in the signal path from the amplifiers.

Case is I ordered new speakers, and this set would
Look stunning using RGB in.

Picture looks fine though!
marsbar is offline   Reply With Quote
Old 23rd May 2021, 11:58 pm   #14
hans
Heptode
 
hans's Avatar
 
Join Date: Jan 2008
Location: Oslo, Norway.
Posts: 608
Default Re: Bang Olufsen 25" hissing static sound at all times L and R

Isn't the 2502 Nicam and 2800 A2 sound? If this is the case then the soundprocessing differs and you can't use the scematic of the 2800 set to find the fault.
hans is offline   Reply With Quote
Reply

Thread Tools



All times are GMT. The time now is 11:41 am.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright ©2002 - 2021, Paul Stenning.