UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > Specific Vintage Equipment > Vintage Audio (record players, hi-fi etc)

Notices

Vintage Audio (record players, hi-fi etc) Amplifiers, speakers, gramophones and other audio equipment.

Reply
 
Thread Tools
Old 19th Oct 2019, 9:21 am   #1
Redgate23
Triode
 
Join Date: Oct 2019
Location: Southport, Merseyside, UK.
Posts: 25
Default Blaupunkt Arkansas 58. Turntable not working.

Hi, I have a Blaupunkt Arkansas 58, the radio works fine but there doesnít seem to be any power to the turntable or the little spot light inside the compartment. Iím not very technical, just wondered if anyone had any tips or helpful hints. Thanks.
Attached Thumbnails
Click image for larger version

Name:	30BA3BE0-0A70-4D19-928F-BAC945BAB59E.jpg
Views:	82
Size:	55.2 KB
ID:	192118   Click image for larger version

Name:	2AAF42FB-1ABF-4D6C-A861-A87016B9A4AF.jpg
Views:	73
Size:	51.4 KB
ID:	192119   Click image for larger version

Name:	1FB0D2A4-FAC7-4256-8EB2-96248EB2DDA9.jpg
Views:	69
Size:	64.3 KB
ID:	192120   Click image for larger version

Name:	5ABC1746-41B6-4A23-BFC1-C09B6B64334B.jpg
Views:	121
Size:	52.6 KB
ID:	192121   Click image for larger version

Name:	F414E528-B40A-4E2D-92C7-5B05CBAE7C69.jpg
Views:	76
Size:	98.8 KB
ID:	192122  

Redgate23 is offline   Reply With Quote
Old 19th Oct 2019, 9:46 am   #2
Audio1950
Dekatron
 
Join Date: Nov 2008
Location: Whittlesey, near Peterborough, Cambridgeshire, UK.
Posts: 3,252
Default Re: Blaupunkt Arkansas 58. Turntable not working.

Let's start with the basics. Remove the circlip from the centre of the turntable (at the base of the spindle) and lift the turntable off. Now turn the control to "start", and see if the motor is turning.
Audio1950 is offline   Reply With Quote
Old 19th Oct 2019, 10:00 am   #3
Edward Huggins
Dekatron
 
Join Date: Sep 2015
Location: Southwold, Suffolk, UK.
Posts: 5,108
Default Re: Blaupunkt Arkansas 58. Turntable not working.

It sounds like the mains power is not getting to the Collaro autochanger or the interior lamp. Check to see if there is a small plug in connector for these at the rear of the radio chassis. Record deck motors very rarely fail.
__________________
Edward.
Edward Huggins is offline   Reply With Quote
Old 24th Oct 2019, 9:22 am   #4
andyrols
Diode
 
Join Date: Feb 2015
Location: Guildford, Surrey, UK.
Posts: 4
Default Re: Blaupunkt Arkansas 58. Turntable not working.

I have a similar machine which had a different problem at the time, but as to how capable you are you might find it would be worth getting a local expert (advertised on these forums) to call out and fix it. It was certainly worth it for me - the vinyl collection is constantly used.
andyrols is offline   Reply With Quote
Old 27th Oct 2019, 11:00 am   #5
Redgate23
Triode
 
Join Date: Oct 2019
Location: Southport, Merseyside, UK.
Posts: 25
Default Re: Blaupunkt Arkansas 58. Turntable not working.

Thanks. We have managed to get the turntable working now but the sound is only coming from the stylus - the sound is fine from the radio but just not from the turntable. Also the arm automatically knocks the record down but then returns to the stand, it doesn’t automatically go onto the record. Not sure what all the wires are for on the back of the cabinet. The interior light is still not working on the side where the radio and turntable is, but the interior light on the cocktail cabinet side is fine.
Redgate23 is offline   Reply With Quote
Old 27th Oct 2019, 9:36 pm   #6
Michael Maurice
Moderator
 
Michael Maurice's Avatar
 
Join Date: Feb 2006
Location: Wembley, Middlesex
Posts: 5,722
Default Re: Blaupunkt Arkansas 58. Turntable not working.

This radiogram dates from 1957 and will need to be electrically and mechanically serviced. Just out of interest, what size records were you playing?
__________________
Forum Moderator

http://www.michaelmauricerepairs.co.uk/
Michael Maurice is offline   Reply With Quote
Old 28th Oct 2019, 6:18 pm   #7
Redgate23
Triode
 
Join Date: Oct 2019
Location: Southport, Merseyside, UK.
Posts: 25
Default Re: Blaupunkt Arkansas 58. Turntable not working.

We were playing 45ís and we had the dial set to 45, so not sure why there is no sound coming from the speakers.
Redgate23 is offline   Reply With Quote
Old 28th Oct 2019, 10:27 pm   #8
'LIVEWIRE?'
Dekatron
 
'LIVEWIRE?''s Avatar
 
Join Date: Mar 2006
Location: N.W. Oxfordshire(Chipping Norton)
Posts: 7,027
Default Re: Blaupunkt Arkansas 58. Turntable not working.

The 'no sound from the amplifier when playing a record could be due to a faulty cartridge. The way to check this is by a 'buzz test' at the pickup lead terminals. Gently pull back any insulating sleeves over the terminals, then touch each wire in turn. One will be the common negative lead which won't produce sound, but, if the amplifier is working with the switch set to 'gram, a loud buzz will be heard with the volume control at maximum. I am assuming that the Arkansas is fitted with a double wound mains transformer so that it's chassis is fully isolated from the mains. If, by any chance it is of the 'live chassis' type, then you must make certain that the mains neutral is connected to chassis, and ideally power the set via an isolating transformer. Not being familiar with continental radiograms, I thought it wise to include this caveat in my post

Last edited by 'LIVEWIRE?'; 28th Oct 2019 at 10:36 pm.
'LIVEWIRE?' is offline   Reply With Quote
Old 29th Oct 2019, 7:25 pm   #9
Redgate23
Triode
 
Join Date: Oct 2019
Location: Southport, Merseyside, UK.
Posts: 25
Default Re: Blaupunkt Arkansas 58. Turntable not working.

Hi, so sorry but we’re both not technically minded! I’ve attached images of the back of the cabinet. We don’t know if everything is connected as it should
Attached Thumbnails
Click image for larger version

Name:	BB43A646-6522-4617-97E8-5F38F8BB23FF.jpg
Views:	60
Size:	55.2 KB
ID:	192626   Click image for larger version

Name:	FA66E244-E6EA-4E0E-AB0A-D2E3F01817CC.jpg
Views:	52
Size:	58.0 KB
ID:	192627   Click image for larger version

Name:	5A6C6486-CC86-4F57-A67D-9969C44DCFCC.jpg
Views:	47
Size:	51.4 KB
ID:	192628  
Redgate23 is offline   Reply With Quote
Old 30th Oct 2019, 9:48 am   #10
'LIVEWIRE?'
Dekatron
 
'LIVEWIRE?''s Avatar
 
Join Date: Mar 2006
Location: N.W. Oxfordshire(Chipping Norton)
Posts: 7,027
Default Re: Blaupunkt Arkansas 58. Turntable not working.

I'm finding it difficult to see much in those images. Maybe other members can see better what's in the pictures than I.
'LIVEWIRE?' is offline   Reply With Quote
Old 30th Oct 2019, 9:56 am   #11
Station X
Moderator
 
Station X's Avatar
 
Join Date: Jan 2003
Location: Ipswich, Suffolk, IP4, UK.
Posts: 15,167
Default Re: Blaupunkt Arkansas 58. Turntable not working.

The pick up sockets are those at the lower right of the first two pictures. You can see a representation of a turntable and tone arm.

Unplug the pick up leads, switch to GRAM and turn the volume to full. Then use a metal object such as a screwdriver to touch the metal part of each socket in turn. If the amplifier is working you'll hear a loud buzz or hum.
__________________
Graham. Forum Moderator

Keep the soldering iron hot.
Station X is offline   Reply With Quote
Old 30th Oct 2019, 11:39 am   #12
Ambientnoise
Heptode
 
Join Date: Feb 2006
Location: Marlborough, Wiltshire, UK.
Posts: 513
Default Re: Blaupunkt Arkansas 58. Turntable not working.

It’s unclear but it seems that the red and black pickup plugs are reversed. Try swapping them after the test in post 11. I think this will only affect only the audio from the turntable, not other problems.
Ambientnoise is offline   Reply With Quote
Old 30th Oct 2019, 3:54 pm   #13
Redgate23
Triode
 
Join Date: Oct 2019
Location: Southport, Merseyside, UK.
Posts: 25
Default Re: Blaupunkt Arkansas 58. Turntable not working.

Hi, how do you switch to Gram, is this a button on the radio at the front or is it a button/switch on the back? Thanks
Redgate23 is offline   Reply With Quote
Old 30th Oct 2019, 4:12 pm   #14
Ambientnoise
Heptode
 
Join Date: Feb 2006
Location: Marlborough, Wiltshire, UK.
Posts: 513
Default Re: Blaupunkt Arkansas 58. Turntable not working.

Think there is a button on the front, prob labelled PU (pick up, an older term for the cartridge/record deck)
Ambientnoise is offline   Reply With Quote
Old 30th Oct 2019, 4:19 pm   #15
Station X
Moderator
 
Station X's Avatar
 
Join Date: Jan 2003
Location: Ipswich, Suffolk, IP4, UK.
Posts: 15,167
Default Re: Blaupunkt Arkansas 58. Turntable not working.

To the left of the Long Wave button?
__________________
Graham. Forum Moderator

Keep the soldering iron hot.
Station X is offline   Reply With Quote
Old 30th Oct 2019, 8:49 pm   #16
Redgate23
Triode
 
Join Date: Oct 2019
Location: Southport, Merseyside, UK.
Posts: 25
Default Re: Blaupunkt Arkansas 58. Turntable not working.

We already had the PU switch on and we can hear a loud buzz/hum when the leads are connected - still no sound, only from the stylus. Not sure what else to try, do you think it needs a new cartridge? Thanks
Redgate23 is offline   Reply With Quote
Old 30th Oct 2019, 10:07 pm   #17
Station X
Moderator
 
Station X's Avatar
 
Join Date: Jan 2003
Location: Ipswich, Suffolk, IP4, UK.
Posts: 15,167
Default Re: Blaupunkt Arkansas 58. Turntable not working.

Have you carried out the test suggested in post #11?
__________________
Graham. Forum Moderator

Keep the soldering iron hot.
Station X is offline   Reply With Quote
Old 30th Oct 2019, 10:34 pm   #18
'LIVEWIRE?'
Dekatron
 
'LIVEWIRE?''s Avatar
 
Join Date: Mar 2006
Location: N.W. Oxfordshire(Chipping Norton)
Posts: 7,027
Default Re: Blaupunkt Arkansas 58. Turntable not working.

I stand to be corrected, but that seems to confirm to me that the Cartridge is faulty.
'LIVEWIRE?' is offline   Reply With Quote
Old 30th Oct 2019, 10:38 pm   #19
Station X
Moderator
 
Station X's Avatar
 
Join Date: Jan 2003
Location: Ipswich, Suffolk, IP4, UK.
Posts: 15,167
Default Re: Blaupunkt Arkansas 58. Turntable not working.

I just wondered whether the buzz/hum was present with the PU lead disconnected. Having the PU lead plugged in shouldn't cause hum. There's also a possibilty the plugs could be reversed.
__________________
Graham. Forum Moderator

Keep the soldering iron hot.
Station X is offline   Reply With Quote
Old 30th Oct 2019, 10:44 pm   #20
'LIVEWIRE?'
Dekatron
 
'LIVEWIRE?''s Avatar
 
Join Date: Mar 2006
Location: N.W. Oxfordshire(Chipping Norton)
Posts: 7,027
Default Re: Blaupunkt Arkansas 58. Turntable not working.

True Graham, the bit about 'buzz/hum when the leads are connected' may be significant
'LIVEWIRE?' is offline   Reply With Quote
Reply

Thread Tools



All times are GMT +1. The time now is 9:33 am.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright ©2002 - 2019, Paul Stenning.