UK Vintage Radio Repair and Restoration Powered By Google Custom Search Vintage Radio Service Data

Go Back   UK Vintage Radio Repair and Restoration Discussion Forum > Specific Vintage Equipment > Vintage Tape (Audio), Cassette, Wire and Magnetic Disc Recorders and Players

Notices

Vintage Tape (Audio), Cassette, Wire and Magnetic Disc Recorders and Players Open-reel tape recorders, cassette recorders, 8-track players etc.

Reply
 
Thread Tools
Old 7th Dec 2017, 8:18 pm   #1
TonyDuell
Nonode
 
Join Date: Jun 2015
Location: Biggin Hill, London, UK.
Posts: 2,289
Default Uher CR210 versions

I have a Uher CR210 portable cassette recorder. It really is a beautiful piece of engineering....

But it does not seem to be the same as the ones in all the service manuals I can find, or the ones on various websites. There are 4 major differences that I have found so far :

1) 'Everybody' says the amplifier PCB contains 2 ICs, the power amplifiers for the 2 channels. Mine does not, it's all discrete transistors

2) The motor is entirely electronically controller. There is no mechanical commutator for startup that was common in Uher motors. I even took the end cap off the motor to check. So the motor driver PCB is different too.

3) It uses hall effect sensors and magnetic rings on the reel spindles to detect tape motion, not optical sensors.

From what I can see the amplifier and motor driver PCBs are not entirely pin-compatible with the ones in the manual. And my unit doesn't appear to have been modified, so I don't think it's a 'bitsa' or a 'marriage' or wharever you call it here.

Does anyone know anything about this version?
TonyDuell is offline   Reply With Quote
Old 20th Dec 2017, 4:37 pm   #2
TonyDuell
Nonode
 
Join Date: Jun 2015
Location: Biggin Hill, London, UK.
Posts: 2,289
Default Re: Uher CR210 versions

I've currently got it in many bits on the bench and am slowly figuring it out. The only PCB to totally agree with the service manual is the 'drive control' which handles the autoreverse, etc. Everything else has some changes, maybe minor (the 'magnet control' is redesigned with silicon transistors), maybe major (the amplifier is totally different and from what I have worked out so far rather better designed).

I am not too surprised that the machine's design was changed over the years. But what did surprise me was that the new amplifier and/or motor could not be fitted in place of the older one without significant changes to the Base Board and it's wiring.
TonyDuell is offline   Reply With Quote
Old 24th Dec 2017, 6:43 pm   #3
TonyDuell
Nonode
 
Join Date: Jun 2015
Location: Biggin Hill, London, UK.
Posts: 2,289
Default Re: Uher CR210 versions

I have now traced out the circuit diagrams (by hand, I don't use a CAD program) for all the PCBs and can confirm that the amplifier is very different to the one in the manual. In many ways it's better, using transistor switches rather than mechanical contacts and with a (hopefully) better equalisation network.

I am now restoring the machine (Mods : if this should be a separate thread I can start one, but it is the same machine). I've fitted a new belt kit and got the mechanism back togehter. Taken everything apart that will sensibly come apart and cleaned it, cleaned the heads and demagnetised them, etc. Now working on the electronics, I've got the base board back in place and after fitting the Drive Control PCB it seems as though the mechanical side works. I can select the direction, the pinch rollers engage, etc. I'll look at the audio side of things in the future.

A few tips for anyone working on one of these machines :

Download the user manual as well as the service manual. The former contains wiring diagrams for many of the adapter cables.

Make up a cable with an 8 pin offset DIN plug on one end and plugs to fit your bench supply on the other (the car power cable diagram in the user manual shows which pins to use). Run the machine off your bench supply. The current limit on that will protect things if you do something silly before any damage is done.

The internal wiring is fragile. Some of the wires are solid core, and almost all are brittle. Wires drop off if you look at them wrongly. Expect to have to resolder things.

If a pinch solenoid appears to pull in and then releases after a couple of seconds, the most likely cause is that it's not pulling in far enough. The solenoid has 2 windings, one (high current) to pull in (controlled by the transistors and capacitors on the Magnet Control PCB, the one on the top side of the drive chassis), the other to hold the armature in. If the armature doesn't come in contact with the core end, then the latter will not hold it, so the solenoid will release when the high current winding is turned off. Check the mechanical adjustment of the clutches and operating levers.
TonyDuell is offline   Reply With Quote
Old 27th Dec 2017, 5:23 pm   #4
TonyDuell
Nonode
 
Join Date: Jun 2015
Location: Biggin Hill, London, UK.
Posts: 2,289
Default Re: Uher CR210 versions

I've had it working, at least in playback mode. Some more comments :

The tracks on the amplfiier PCB are fragile, and as the board is densely packed it is too easy to press on components and break tracks when pulling the board out. Take care! You do not want to know how I found that out, suffice it to say I spent a couple of hours tracking down missing signals.

I had another intermittent problem, the unit would loose 1 channel which seemed to come back if I pressed on the body (not the contacts) of the head switch (on top of the direction 2 pinch solenoid). No, not bad contacts there. It turned out to be bad contacts on the 21 pin connector between the amplifier PCB and the base board which got disturbed when I pressed on the switch body!

If you are testing the bias/erase oscillator you must have the erase head connected (red plug on the Magnet Driver PCB). The erase head is in parallel with part of the oscillator transformer and thus reduces the inductance, increasing the frequency. With the head connected I get a reasonable 70-odd kHz. With it disconnected I get around 16kHz. And yes I did try to find a 'fault' before I realised what was going on!

-tony
TonyDuell is offline   Reply With Quote
Reply

Thread Tools



All times are GMT +1. The time now is 1:03 pm.


All information and advice on this forum is subject to the WARNING AND DISCLAIMER located at https://www.vintage-radio.net/rules.html.
Failure to heed this warning may result in death or serious injury to yourself and/or others.


Powered by vBulletin®
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright ©2002 - 2018, Paul Stenning.