View Single Post
Old 22nd Jul 2021, 10:14 am   #1
Murphy1969
Diode
 
Join Date: Jul 2021
Location: Runcorn, Cheshire, UK.
Posts: 6
Default Murphy A855g Record Player - Intermittent power issue.

Hi - I recently acquired a Murphy AU855G record player which worked fine for a couple of weeks, then when I turned it on one day recently , although I got a hum from the speakers, the red power light didn't come on and the deck didn't function - turntable wouldn't turn etc.

A week later, I tried again and all was fine again. I have used the record a fair amount recently and used the record player last night and the same issue has occurred today - I get the normal speaker hum, but no light and no action from the deck :-(, and the red power light doesn't come on.

I know little about these things, but could it be a simple wiring issue /
loose connection somewhere? I note the power cable comes in at the back of the unit and goes underneath the deck to the front of the unit to the speaker etc. I am thinking there is a power feed underneath the deck itself (powering the deck) which may need attention?

I note there are 4 screws which seem to be holding the deck onto the main unit. Will it be simple enough to remove these screws and lift the deck to take a look? Is there anything I need to be careful of, apart from disconnecting from the mains of course .

I believe it is the same construction as the Bush SRP51 and has a BSR UA65 autochanger.

Any help/advice appreciated.

Thanks,

Ian
Murphy1969 is offline   Reply With Quote