Thread: Rotel RVC240
View Single Post
Old 15th Sep 2020, 10:09 pm   #1
crackle
Dekatron
 
crackle's Avatar
 
Join Date: Mar 2011
Location: Basildon, Essex, UK.
Posts: 3,771
Default Rotel RVC240

Oh dear I seem to be attracting all sorts of CB's for repair, its a good job this is a hobby I enjoy.

This one is a Rotel RVC 240 which was completely dead on TX. This turned out to be something to do with Q2, or at least the fault disappeared after removing the transistor testing it and refitting it.

I have just been doing some further tests and found that the transmit was off frequency.
I cant get the PLL adjustment correct, the lowest I can get the frequency is 10.30MHz and that is with the trimmer cap CT2 removed completely from the circuit.
I thought that maybe C3 was off but that does not exist on the board.
I have checked and adjusted TP-1 and T1 for 4 volts on Ch40 and can confirm on Ch1 it is 2.3 volts on RX and TX.
I have checked my frequency counter against a known good radio with its own frequency display and it is spot on.

I am at a loss as to how to correct the frequency of the oscillator.

Please can someone advise what else effects the oscillator frequency that I can check to see if it has wandered off spec.

If anyone needs more service information it can be found here on CB tricks. https://www.cbtricks.com/radios/rote...rvc_240_sm.pdf

Thanks
Mike
Attached Thumbnails
Click image for larger version

Name:	rvc240a.jpg
Views:	36
Size:	121.8 KB
ID:	215775  
__________________
BVWS Member, 2E1MJE
The KB Museum

My collection in the Radio Museum
crackle is offline   Reply With Quote