View Single Post
Old 16th Aug 2021, 10:45 pm   #3
rambo1152
Dekatron
 
rambo1152's Avatar
 
Join Date: May 2010
Location: Manchester, UK.
Posts: 3,018
Default Re: Westclox EM21 electric clock

Electrically your clock movement couldn't be simpler, its just a coil of wire across the mains.
So there are two possibilities, either something mechanically stuck, which is probably fixable by cleaning and re-lubricating, or the coil, the motor winding, has gone open circuit, and that could be very difficult to fix.

Do you have a multi-meter?

If so, with the clock unplugged, can you disconnect one side of the motor and measure its resistance ?
I just tried it on a similar clock and got 8 kilo Ohms. See if you get a reading in that ball-park.

If it's difficult to isolate the motor, as long as you remove the florescent tube, you should be able to measure its resistance between the live and neutral pins of the plug.



Amusing postscript.
I tried measuring one of my own clocks at the plug.

I rewired it some time ago with a modern plug and modern twisted pair double insulated flex salvaged from some blown incandescent xmas lights, as the flex looks retro.

Click image for larger version

Name:	clock1.jpg
Views:	102
Size:	113.3 KB
ID:	239516

My meter gave a reading of infinity, open circuit, yet the clock works perfectly.

Anyone care to guess why this was?
__________________
--
Graham.
G3ZVT
rambo1152 is offline   Reply With Quote