View Single Post
Old 29th Mar 2019, 11:18 am   #10
boombox
Pentode
 
Join Date: Mar 2012
Location: Rotherham, South Yorkshire, UK.
Posts: 145
Default Re: Using a slide Switch 2A to switch between POTS and FreePBX

Thanks again Rambo. So I had a productive evening last night. It would have been even more productive if my four year old son hadn't kept waking up and interrupting progress!

So basically....

Line 1:
I changed my NAT mapping setting, the network jitter level and buffer adjustment, register expires, make/ans call without reg, use auth ID, auto pstn fallback. I didn't change the SIP port.
PSTN: I changed my NAT mapping setting, I didn't change the SIP port, I did change the make/ans call without reg, did rename user/auth ID to 1-pstn, changed VoIP default DP, turned off detect voip long silence, PSTN silence changed to medium.
Disconnect tone and port impedance left as they were. Current limiting turned off. Think I increased PSTN to SPA gain to match.

I was curious as to why our disconnect tones and port impedances differed.

I cautiously tried, once I got your setup working, to put in place "my" dialplan of:
(999<:@gw0>S0|112<:@gw0>S0|1[1-3]x|1[45]xx|08001111|0845464x|0[58]00xxxxxx|01[2-9][02-9]xxxxxx|0[1-9]xxxxxxxxx|[2-9]xxxxx|00xxxxxxxx.|*x.)
and sure enough - with all your settings it worked! The reason I did this was to make dialling out quicker. If I'm not mistaken it eliminates the delay between dialling and Asterisk deciding I'm finished dialling.

I did have to leave my proxy IP address with a :port after it and I had to leave my SIP ports set at different values, I guess either we're on different versions of FreePBX/Asterisk or you're using the older port settings? I also found I couldn't use auth-id on the PSTN tab, presumably beacuse it didn't match the FreePBX settings.

But it's brilliant! It's really great! It's been about a week of faffing with this most days and just by quickly alt-tabbing between your settings and mine everything's working!

New challenges:

-I'd like to get my Cnet trunk working and I'd like to get my Sipgate trunk working. At the moment something's going wrong with Sipgate, it just says "timed out" in the Asterisk CLI. As if a port is blocked on my router. I've made sure SIP ALG is turned off. I haven't done any port forwarding though. I didn't think I'd need to do that as I'm not exposing a service on my network to the internet, I'm trying to connect TO a service, aren't I?

I'd also like to find a way to present callers with an IVR after a certain point in the evening but I'm sure I can google for that.

Would be interested to hear what other fun things you do with your setup!
boombox is offline