UK Vintage Radio Repair and Restoration Discussion Forum

UK Vintage Radio Repair and Restoration Discussion Forum (https://www.vintage-radio.net/forum/index.php)
-   Vintage Television and Video (https://www.vintage-radio.net/forum/forumdisplay.php?f=37)
-   -   Bush TV66. (https://www.vintage-radio.net/forum/showthread.php?t=156569)

linescan87 15th May 2019 10:30 pm

Bush TV66.
 
2 Attachment(s)
Hi All,

I collected this set at the weekend from Mikey's with thanks to Courtney for collecting it for me some time back from Shaun who generously offered it here f.o.c.

At Mikey's we quickly got it on the table and pulled the timebase deck out. All sorts of strange things had been done including a diode and polo dropper to replace the two PY82 rectifier valves, although there heaters were left wired in for ballast. There were quite a few repairs carried out in the past with odd looking components not to mention a back panel from a GEC bt2748 and a bottom panel from a KB radio!

It was soon decided that it would be more trouble than it was worth so I boxed it up and we got that now famous GEC on the operating table instead.

I was keen however to see how it would work as-is and having been spurred on by HKS's success with his newly acquired Murphy I got it up on the bench this evening. First power up produced a slight groaning noise from inside the timebase panel and not much else. I soon discovered one of the fuses was open. With that replaced and nothing else to loose I gave her the beans once more. She soon came up with a full bright unfocused raster!

A bit of fiddling about and we had test card C. Had it on for half an hour and the usual thing with the width coming in started, so I'll needed to dry out the lopt with DC.

So there you are lads, it only needed a fuse!!

Great fun,
John Joe.

https://youtu.be/e6pVDRVornc

Heatercathodeshort 16th May 2019 8:03 am

Re: Bush TV66.
 
Fake News! I don't believe it! Ha ha. To think we could have put that TV66 on the bench and had it working in 30 mins...It just proves that appearances can definitely be deceptive. Don't be put off by a shoddy frock...Good luck with it. John.

linescan87 16th May 2019 9:51 am

Re: Bush TV66.
 
To be honest John I didn't believe it myself, I thought something would have given up the ghost especially with that rectifier mod.

I have another 3 already with that chassis, they've all been easy enough to get going. The tube is a real cracker to.

Cheers,
John Joe.

linescan87 16th May 2019 12:40 pm

Re: Bush TV66.
 
1 Attachment(s)
So I had the LOPT on last night to dry out. Tried it again today and it's been solid for over 2 hours, so it obviously wasn't too bad.

Still needs a good bit of tidying as the replacement polo mint droppers are all dry jointed, a lot of dodgy work to tidy and I'd like to put the PY82's back in circuit.

I wonder if the work was carried out get it going for the end of 405, the components are 80's looking.

Cheers, John Joe.


All times are GMT +1. The time now is 4:00 pm.

Powered by vBulletin®
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright ©2002 - 2019, Paul Stenning.