UK Vintage Radio Repair and Restoration Discussion Forum

UK Vintage Radio Repair and Restoration Discussion Forum (https://www.vintage-radio.net/forum/index.php)
-   Vintage Computers (https://www.vintage-radio.net/forum/forumdisplay.php?f=16)
-   -   Zx81 (https://www.vintage-radio.net/forum/showthread.php?t=164648)

John Earland 14th Mar 2020 11:40 pm

Re: Zx81
 
Quote:

Originally Posted by Slothie (Post 1225563)
Oddly enough I did the same thing at the same time for my chicklet keyboard commodore PET 2001. i got a DEC VT52 keyboard from a computer scrap place in Maldon, Essex, cut all the tracks on the PCB and rewired it with single core wire from phone cable my dad liberated from a skip during a refit of the office he worked in. I made a 2-way adapter from veroboard and header connectors so you could use both keyboards as the mood took me (original keyboard for graphics, nrw one for actual text). Then we made a case for the keyboard from plywood painted to match the PET connecting to the adapter by a rainbow ribbon cable. Labelling the keys that needed it was done by writing on bits of paper and sellotaping onto the keys which was crude but worked! Twenty years of being in the loft has meant most of them have dropped off, but they lasted for the 8 or so years it was my main computer and was a joy to use.

Fantastic!

John Earland 14th Mar 2020 11:44 pm

Re: Zx81
 
Quote:

Originally Posted by SiriusHardware (Post 1225543)
Turning the transistor pinout into a practical layout, this is how to physically wire everything up. (See attached). I've laid it out so that the incoming +5V and the incoming video-in arrive from roughly the right place and direction.

When you cut the incoming video-in and +5V wires do it about 5-7mm inside the modulator housing, the transistor's base and collector leads can then be soldered directly to the ends of the incoming wires.

The resistor can be soldered between the transistor's emitter and the inside of the modulator case which is a handy 0V point - if you do that, do it low enough down the inside so the modulator lid can still be fitted on afterwards.

That sounds perfect! All neatly hidden away inside. Probably need to insulate the exposed pins too.

John Earland 15th Mar 2020 12:10 am

Re: Zx81
 
Quote:

Originally Posted by SiriusHardware (Post 1225543)
Turning the transistor pinout into a practical layout, this is how to physically wire everything up. (See attached). I've laid it out so that the incoming +5V and the incoming video-in arrive from roughly the right place and direction.

When you cut the incoming video-in and +5V wires do it about 5-7mm inside the modulator housing, the transistor's base and collector leads can then be soldered directly to the ends of the incoming wires.

The resistor can be soldered between the transistor's emitter and the inside of the modulator case which is a handy 0V point - if you do that, do it low enough down the inside so the modulator lid can still be fitted on afterwards.

Would there be any need to cut the +5v wire? Could I just solder into it?

SiriusHardware 15th Mar 2020 12:14 am

Re: Zx81
 
It is not essential to cut the +5V but if you do not it will leave the modulator circuitry powered unnecessarily.

John Earland 15th Mar 2020 12:31 am

Re: Zx81
 
Ah-I see - yes thank you. Lovely neat solution you gave me. I shall do it when the transistor arrives!

On a slightly different note, I obtained another ZX81 today-checked inside, unfortunately it has the early ULA you mentioned. Tried it on my modern TV and it gave a black screen-my original ZX81 does work on the modern tv though picture is a bit wobbly but it does work through the aerial socket. Will try the early ZX81 on the crt tomorrow.

Interestingly for my original ZX81, which I will modify, when I plug in a 16k RAM pack the picture quality is significantly reduced on my lcd tv. Very grainy and stripey-Looks like an awful lot of interference. Maybe the mod will help!!

Refugee 15th Mar 2020 2:35 am

Re: Zx81
 
Quote:

Originally Posted by Slothie (Post 1225563)
Oddly enough I did the same thing at the same time for my chicklet keyboard commodore PET 2001. i got a DEC VT52 keyboard from a computer scrap place in Maldon, Essex, cut all the tracks on the PCB and rewired it with single core wire from phone cable my dad liberated from a skip during a refit of the office he worked in. I made a 2-way adapter from veroboard and header connectors so you could use both keyboards as the mood took me (original keyboard for graphics, nrw one for actual text). Then we made a case for the keybosrd from plywood painted to match the PET connecting to the adapter by a rainbow ribbon cable. Labelling the keys that needed it was done by writing on bits of paper and sellotaping onto the keys which was crude but worked! Twenty years of being in the loft has meant most of them have dropped off, but they lasted for the 8 or so years it was my main computer and was a joy to use.

My mate did better.
He bought a replacement keyboard sticker and chopped all the legends out and stuck them to the key caps. He bought several if I remember rightly as they were pretty cheap. There was a sacrificial keyboard for stripping and tracing.
The keyboard was a big chunky item made out of folded aluminum with enough space for the ZX81 and the guts of the mains adapter easily.
The computer the donor keyboard came from had a CPU that took up a whole room.
The screens were so heavy that hardly any got pulled out of the skip.

SiriusHardware 15th Mar 2020 8:44 am

Re: Zx81
 
Quote:

Originally Posted by John Earland (Post 1225605)
when I plug in a 16k RAM pack the picture quality is significantly reduced on my lcd tv. Very grainy and stripey-Looks like an awful lot of interference. Maybe the mod will help!!

It may certainly be very revealing. If the picture is still not much improved after the mod and gets noticeably worse when you have a RAM pack plugged in that would suggest that there may be problems with the onboard PSU circuit, or, as others suggested earlier, the external mains PSU.

If the 'new' ZX81 also came with an original PSU, try running the 'old' ZX81 on the 'new' PSU to see if that makes any difference to your video quality.

John Earland 15th Mar 2020 9:23 am

Re: Zx81
 
That’s a great idea-I will try it. I do actually have another 9v dc psu too. It powers an old Binatone Mk IV game console from the 1970s and has the same connection. The Binatone works well on the crt-picture a little wobbly but very usable. I could try that one too.

Slothie 15th Mar 2020 9:40 am

Re: Zx81
 
Inside the RAM pack there should be a 22uF electrolytic across the supply rails. If this has gone bad then it wont be supressing all the noise generated by the 12v inverter circuit used to supply the DRAM chips. This is likely the source of your interference.

Schematic & info:
https://www.myprius.co.za/ZX81.htm

John Earland 15th Mar 2020 9:54 am

Re: Zx81
 
Thank you for that-I shall check.

SiriusHardware 15th Mar 2020 10:24 am

Re: Zx81
 
Quote:

Originally Posted by John Earland (Post 1225647)
I do actually have another 9v dc psu too. It powers an old Binatone Mk IV game console from the 1970s and hasn the same connection. The Binatone works well on the crt-picture a little wobbly but very usable

If two completely different RF connected devices give you a rough / wobbly picture on the same TV then I can not help but wonder if it is the TV rather than the devices which has the problem.

When swapping PSUs between different devices, beware of polarity - roughly 50% of PSUs from that era had positive on the tip of the plug, the other 50% negative on the tip of the plug. Use your meter to make sure the polarity of the Binatone PSU is the same before trying to run either of the ZX81s on it. I seem to remember the ZX PSUs are tip=negative, but don't take my word for it, check.

John Earland 15th Mar 2020 3:24 pm

Re: Zx81
 
Ah-right! I will double check!

julie_m 15th Mar 2020 3:50 pm

Re: Zx81
 
The ZX81 supply is positive tip, and -- by happy accident or cunning design -- will not cause any lasting damage if plugged into the EAR or MIC socket for long enough to notice something is amiss. (Applying negative voltages to inputs of MOS ICs with protection diodes, even when unpowered, is a bad idea. Sinclair would probably have known that when choosing the wiring and reckoned accordingly, selecting the option least likely to be damaged by misconnection without adding expensive protection diodes, resistors or fuses!)

The Spectrum supply used a "barrel" connector with negative inside, so no possibility of misconnection. I don't know if the change was for better reliability (only one sprung contact) or user-proofing.

John Earland 15th Mar 2020 5:49 pm

Re: Zx81
 
Thank you-that’s really interesting. There’s so much I don’t know! There’s so much I don’t know that I don’t know too!

SiriusHardware 15th Mar 2020 7:22 pm

Re: Zx81
 
Just hauled out my original ZX81 'Ski Jump' power supply and yes, Julie is right, tip positive on the ZX81, not tip negative as per my (obviously faulty) memory.

John Earland 15th Mar 2020 8:19 pm

Re: Zx81
 
Okay - an update! I have two ZX81s now, both with 16k RAM packs. Both with their own PSUs and both with their own TV cables.

My original ZX81 (the subject of this thread) works on the RF of both the portable crt TV and the LCD - though poor picture quality in both cases. I will be modifying the ZX81 to hopefully improve this. It works on about channel 36 but with wobbly picture as discussed on both the LCD and CRT TVs.

I have tried powering this ZX81 with the two different PSUs without any discernible difference in the quality of the video output on either of the two TVs.

I have also tested the ZX81 with the Sinclair RAM pack and the MEMOPACK RAM pack. Using either of these RAM packs results in the same very distorted video output which can’t be corrected with fine adjustments to either of the two TVs. I’ve tested these RAM packs on the second ZX81 and its video output remains steady and is totally unaffected by them. This ZX81 is an early model unfortunately which generates a dark screen. However, from what I can see, the picture is quite stable no matter which PSU or RAM pack I use with it. If the picture was white it would be perfect!

My assumption that the ZX81 would not save or load programs was (potentially) false because I have been using stereo cables (mono ones ordered) so I do think that this will be okay.

So, I can deduce that:
1. There is nothing wrong with either of the PSUs.
2. There is nothing wrong with either of the RAM packs.
3. There is nothing wrong with the RF leads.
4. There remains a problem with the original ZX81. Not only is the video output poor it is affected by the attachment of the RAM packs which it shouldn’t be of course.

I will of course be testing this when I have undertaken the modification. I would be grateful for any comments, advice and guidance.

Thank you all so much for your input thus far. I really do appreciate you taking the time to help me.

SiriusHardware 15th Mar 2020 9:07 pm

Re: Zx81
 
Nice methodical approach, made possible by having two of everything. For the 'dark picture' problem with the second ZX81 you basically have a number of options:-

-Re-sell it. It will eventually end up in the hands of someone who has a TV which is retro enough to work with it.

-Fit an additional bit of electronic circuitry which reinstates the missing portion of the video signal. This is not a particularly simple circuit so it would be best to buy it as a kit, but looking around, such kits can cost more than a replacement 2C210 ULA and are more complicated to fit which makes no sense, so the next option is :-

-Obtain and fit a genuine replacement 2C210 ULA. Unfortunately these are not particularly cheap - often more expensive than a whole ZX81 which already has the 2C210 ULA.

- At various times enterprising people have produced cheaper reverse-engineered modern versions of the ULA - typically a PCB with the 40-pin footprint of the original IC, but with one or more surface-mounted ICs on it. Unfortunately these tend to be made in fairly small batches and the two examples I found are currently sold out, although more may be made available in future.

For the original ZX81 I am now inclined towards thinking there is a problem with noise on the internal power supplies, the most likely cause of which would be tired capacitors - the more so if the machine still has poor / unstable video output when modified for composite video output.

John Earland 15th Mar 2020 9:17 pm

Re: Zx81
 
Thank you - that’s really useful to know. I have found someone online who sells something called Chroma-81 which attaches to the ZX81 which generates SCART RGB signals - however, it costs 72 for the basic model but you do get other interfaces and 16k RAM - there are other things too I think so may be the best thing to do- other than resell it. Which I might!

John Earland 15th Mar 2020 9:19 pm

Re: Zx81
 
With regards the noise on internal power supplies on my original ZX81, I think I’d like to try to replace those capacitors. Do you think the video modification would help though too or should I replace the capacitors anyway?

John Earland 15th Mar 2020 9:34 pm

Re: Zx81
 
Hi, I found this which seems promising? https://www.sellmyretro.com/offer/details/3712


All times are GMT +1. The time now is 12:13 am.

Powered by vBulletin®
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright ©2002 - 2020, Paul Stenning.