UK Vintage Radio Repair and Restoration Discussion Forum

UK Vintage Radio Repair and Restoration Discussion Forum (https://www.vintage-radio.net/forum/index.php)
-   Vintage Test Gear and Workshop Equipment (https://www.vintage-radio.net/forum/forumdisplay.php?f=36)
-   -   AVO 8 Mk.III A.C. voltage not functioning. (https://www.vintage-radio.net/forum/showthread.php?t=82459)

brunel 14th Apr 2012 7:10 pm

AVO 8 Mk.III A.C. voltage not functioning.
 
All other ranges are ok. It appears to be one of the switches on the AC switch cam/range switch.

On any of the voltage positions, I can see the leaf moving up, but not quite making contact with the leaf above, it is only a minute fraction out.

On any of the AC current ranges, the same switch moves slightly more and does make contact.

What is the correct and easiest way of solving this?

pmmunro 14th Apr 2012 7:16 pm

Re: AVO 8 Mk.III A.C. voltage not functioning.
 
If the switch leaves concerned are making on some ranges but not on others it could be worth checking that the face cam has not come slightly loose and turned on the end of the knob spindle.

PMM.

brunel 14th Apr 2012 7:21 pm

Re: AVO 8 Mk.III A.C. voltage not functioning.
 
Thanks for the info. PMM.

Is it fairly easy to detect this problem?

And what do I do to fix it?

brunel 14th Apr 2012 10:04 pm

Re: AVO 8 Mk.III A.C. voltage not functioning.
 
I checked the face cam, it was secure, I did tighten the securing screws another quarter turn.

One thing I did notice, the lobe that actuates the voltage switch appeared to be
lower than the lobe that actuates the current switch by approx 1mm.

I took what I believe to be the only course left, a slight adjustment of the lower leaf switch towards the face cam, only just enough room to grip it with a small pair of long nose pliers.

The switch now makes contact on all AC volt ranges, and this old AVO now reads correctly on AC volts.

MrElectronicman 14th Apr 2012 10:50 pm

Re: AVO 8 Mk.III A.C. voltage not functioning.
 
I had exactly the same problem with my AVO, and I used the same technique.

If that have not worked I was prepared to remove the leaf switch, disassemble it and adjust the springs. Shades of the old GPO when I was a youth-in-training in the local telephone exchange.

pmmunro 15th Apr 2012 8:16 am

Re: AVO 8 Mk.III A.C. voltage not functioning.
 
As you will see from previous posts, it is very likely that the Avo leaf switches are directly related to PO 3000 style relay contacts.

Good to know another Avometer has been restored to full health.

PMM


All times are GMT. The time now is 6:31 pm.

Powered by vBulletin®
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright ©2002 - 2017, Paul Stenning.